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MicroStation V8i Overview

Main Themes for MicroStation V8i

Key Themes of MicroStation V8i
– Conceptual Design
– Drawing Composition and Dynamic Views
– Geo-Coordination
– Print Organizer
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– Customization
– Rendering and Animation

Version number – 08.11.07.171
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Complete What’s New List

Application Window Layout Changes
Menu Changes
3D Modeling Enhancements
AutoCAD Interoperability
Auxiliary Coordinate Systems Update
Change Attributes Enhancements
Color Enhancements
Detailing Symbols Enhancements

Graphics Display Enhancements
Levels Enhancements
Models Enhancements
Named Expressions
Printing Enhancements
Project Explorer and Link Set Update
Raster Manager Enhancements
References Enhancements
Selection Enhancements
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Detailing Symbols Enhancements
Dynamic Views
Format Interchange Enhancements
Geographic Coordinate System Support
Global Origin Enhancements
Global Positioning System Device Support
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Selection Enhancements
Sheet Composition Enhancements
Task Navigation Enhancements
Text Enhancements
User Interface Enhancements
User Preferences Enhancements
Views Enhancements
Visualization Enhancements



12/2/2009

2

Application Window Layout Changes

• The Tasks dialog is the default task navigation interface. This dialog is docked to left-hand edge 
of the application window.

• The Main task is embedded in the Tasks dialog
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Menu Changes

File menu changes 

• Selecting Import > CAD Files opens the Import dialog.

• Selecting Export > SVG opens the .

• Selecting Export > Maxwell Scene opens the .

• Selecting Export > OBJ opens the .
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• Batch Print is removed and has been replaced by Print Organizer. Selecting Print Organizer opens 
the Print Organizer dialog.

Element menu changes 

• Detailing Symbol Settings is removed. It is replaced by Detailing Symbol Styles, which opens the 
Detailing Symbol Styles dialog. In this dialog you can create and edit detailing symbols.

• Selecting Element Templates opens the Element Templates dialog, which in the previous edition 
was accessible in the Customize dialog.
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Menu Changes
Settings menu changes 

• Selecting Display Styles opens the Display Styles dialog.

• Locks > Depth Lock is removed. It is no longer used.

• The Rendering submenus have been reorganized. Selecting Rendering > Settings opens the .

• Selecting Rendering > Maxwell Materials opens the .

• Snaps > Tangent From has been renamed Tangent Point.

• Snaps > Perpendicular From has been renamed Perpendicular Point.

Tools menu changes 

• The Tools menu has been reorganized. All toolboxes are accessible from the Tools menu. Each 
tool appears in only one toolbox.
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• You can select tools and view controls directly from the Tools menu.

• For example to select the Scale tool, select Tools > Manipulate > Scale. To open the Manipulate 
toolbox, select Tools > Manipulate > Open as ToolBox.

• The Main submenu returns to provide more convenient access to child toolboxes of the Main 
toolbox.

• The Geographic submenu provides access to geographic tools.

Utilities menu changes 

• The Render menu item's submenus have changed. The submenus are View, Fly Through, Solar 
Study, and Animation.

• Selecting Named Expressions opens the Named Expressions dialog.

• The Generate Section menu item is removed.
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3D Modeling Enhancements
Unified workflow for all 3D modeling tools 

• All 3D modeling tools now have a unified workflow that covers that way that you select items for creation 
and modification and how you can modify them interactively.

Select edges and faces of solids and surfaces for modification 

• Typically, selecting edges, faces, or vertices, for solids and surfaces is as follows:

• Generally — select single items with a data point, and use <ctrl-Data> for additional items.

• Faces — select the solid/surface first, then dynamics lets you select face(s).

• Back Faces — snap to an edge or vertex of a back face.

• Edges/Vertices — direct selection, or through dynamic selection. 

Interactive handles to control 3D objects during creation 

• Interactive handles let you control aspects of 3D objects during creation. For example, you can reverse 
the direction of surface normals interactively, during construction of fillets, by clicking the direction 
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handles.

3D Primitives 

• As well as the existing primitive solids and surfaces — Slab, Sphere, Cylinder, Cone, Torus, and Wedge —
tools for new primitives have been added to the Primitive Solids and Primitive Surfaces toolboxes. These 
are:

• Pyramid 

• The Pyramid Surface and Pyramid Solid tools create pyramid shaped objects. When Method is set to 
Rectangle, a roof-like shape may be constructed with a ridge line at the top.

• Elliptical Cone 

• The Elliptical Cone Surface and Elliptical Cone Solid tools create a SmartSolid/SmartSurface that is a 
transition between two ellipses.

• Ellipsoid 

• The Ellipsoid tool creates an ellipsoid solid that is defined by three radii.

• Polyhedron 

• The Polyhedron tool creates a regular polyhedron SmartSolid with 4, 6, 8, 12, or 20 facets.
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3D Modeling Enhancements
Dome Surface 

• The Dome Surface tool creates a surface that is a portion of a sphere, defined by cutting the sphere 
dynamically along its axis.

B-Spline Curve Tools 

• Several new tools have been added to the Modify B-spline Curves toolbox for modifying and manipulating 
B-spline curves.

Edit Weights 

• The Edit Weights tool lets you select a B-spline curve, then a control point, to modify its weight using the 
text field input or the slider. 

Edit Kinks 

• The Edit Kinks tool lets you insert or remove kink points. A kink point is a point on the curve where, 
potentially, curves can have a cusp or sharp point.
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Edit Knots 

• The Edit Knots tool lets you insert or remove knots. A knot is a point on the control polygon of a B-spline 
curve.

Edit Nodes 

• The Edit Nodes tool lets you insert node points into a curve, or move them by dragging. Nodes are points 
on B-spline curves that can be moved to change the shape of the curve.

Curve Handlebar 

• The Curve Handlebar tool lets you identify a B-spline curve and then define a point on it where the tool 
displays three handles. The side handles let you deform a curve´s tangent direction at the defined point. 
The middle handle lets you drag the point to change the shape of the.

Split Curve 

• The Split Curve tool lets you split a B-spline curve by one of the following methods:

• By Numbers — splits the curve into equal arc lengths.

• At Kink Points — splits the curve at all sharp or cusp points
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3D Modeling Enhancements
Dedicated creation tools for Solids and Surfaces 

• Solids and surfaces now have separate toolboxes, and tools. The following tools are located in the Create 
Solids and Create Surfaces toolboxes.

Solid by Extrusion 

• The Solid by Extrusion tool creates an extruded solid from closed profile curves, or faces of solids or 
surfaces. Open profiles such as arcs and lines cannot be selected for use with this tool. In these cases, use 
the Surface by Extrusion tool.

Solid by Revolution 

• The Solid by Revolution tool creates a revolved solid from closed profile curves, or faces of solids or 
surfaces. Open profiles such as arcs and lines cannot be selected for use with this tool. In these cases, use 
the Surface by Revolution tool.

Solid by Extrusion Along 
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• The Solid by Extrusion Along tool creates a solid by extruding closed profile curves, or faces of solids or 
surfaces, along a curve or path. Settings control the alignment of the profile as it is extruded.

• Normal — profile maintains a normal (perpendicular) orientation relative to the path.

• Parallel — profile remains parallel to its original orientation.

Surface by Extrusion 

• The Surface by Extrusion tool is similar to the Solid by Extrusion tool, except that both open and closed 
profiles may be selected and a surface is created.

Surface by Revolution 

• The Surface by Revolution tool is similar to the Solid by Revolution tool, except that both open and closed 
profiles may be selected and a surface is created.

Surface by Extrusion Along 

• The Surface by Extrusion Along tool is similar to the Solid by Extrusion along Curve tool, except that both 
open and closed profiles may be selected and a surface is created.
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3D Modeling Enhancements

Solid modeling creation and modification tools 

• Several new tools have been included for creating and modifying solids. These are located in the Create 
Solids and Modify Solids toolboxes.

Linear Solid 

• The Linear Solid tool lets you create a wall like solid (rectangular section) by drawing a line string.

Replace Face 

• The Replace Face tool lets you replace a face of a solid with a selected surface. The result is a solid that 
has the selected surface as one of its faces.

Surface modeling creation and modification tools 
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• The following new surface modeling tools are located in the Create Freeform Surfaces, Modify B-spline 
Surfaces, and Surface Utilities toolboxes.

Loft Surface by Vertices 

• The Loft Surface by Vertices tool lets you construct a B-spline surface between two profiles, which can be 
edges of existing solids or surfaces. During construction, 3D handles let you interactively control the 
matching points for the profiles.

Surface by Edge Curves 

• Previously known as the Construct Surface by Edges tool, the Surface By Edge Curves tool, lets you select 
2 to 6 curves to create a surface. This enhanced version of the tool lets you select edges of solids or 
surfaces as the curves, as well as the standard curve types — lines, line strings, shapes, arcs, curves, B-
spline curves, complex chains, and complex shapes. 

• When 3 or more edges are selected, they must form a closed loop.
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3D Modeling Enhancements

Surface by Corner Points 

• The Surface By Corner Points tool lets you construct a surface by entering four points, which may 
be non-planar.

Surface Handlebar 

• With the Surface Handlebar tool you can modify the shape of a surface by manipulating handles. 
After identifying the surface, handles display that let you adjust the surface.

Twist Surface 

• The Twist Surface tool lets you twist a B-spline surface, or a mesh element, about a defined axis.

Planar Slice 
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Planar Slice 

• The Planar Slice tool is a simplified replacement for the Generate Section utility and lets you 
create a planar section by Element, Points, or by View.

Unroll Developable Surface 

• The Unroll Developable Surface tool lets you unroll a surface onto a plane using an approximation 
process. The Number of Points setting determines how many sample points are taken to create 
the surface.
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3D Modeling Enhancements

Mesh modeling creation and modification tools 

• Enhancements to the mesh modeling tools includes the addition of the following new tools:

Place Grid Mesh 

• The Place Grid Mesh tool lets you define a mesh element by entering a grid of points defining the 
vertices of the resultant mesh element.

Developable Mesh from Curves 

• The Developable Mesh from Curves tool lets you use two curves and create a mesh 
approximation of the developable surface between them. The resulting mesh will be made up of 
quadrilateral facets. You then can use the Unfold Mesh tool to lay the mesh onto to a plane. 

© 2008 Bentley Systems, Incorporated
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Convert Mesh to Surface 

• The Convert Mesh To Surface tool lets you convert a mesh element to a B-spline surface. The 
mesh element should be of the kind that does not wrap around. Typically, meshes that are used 
to represent DTMs are good candidates for this tool.
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AutoCAD Interoperability

• In the MicroStation V8i Edition, support for reading and writing the DWG file format to AutoCAD 
2009 is extended.
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Auxiliary Coordinate Systems (ACS) Update

A major enhancement to the Auxiliary Coordinate Systems functionality is the ability to assign ACS’s 
to individual views.

Per view Auxiliary Coordinate Systems 

• A new tool in the ACS toolbox lets you assign Auxiliary Coordinate Systems to each view. You can 
create an ACS for a view with the Define ACS by View tool. You can make the ACS view-
independent by turning on a check box. When a view- independent ACS is active, and the ACS 
triad setting is enabled for the view, the X, Y arrows are displayed as dashed in the view.

• To retain the per view ACS setting for the next session  you must select File > Save Settings
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• To retain the per-view ACS setting for the next session, you must select File > Save Settings.

• When a model created in an earlier version is opened and the ACS Plane lock is not enabled, a 
view-independent ACS with an origin of the view center at active depth is created. This lets you 
start working with the geometry created in the same place as it would have been in the earlier 
version (at the Active Depth).

Depth Lock is no longer used 

• Active Depth is no longer used, because the location of unsnapped points is controlled by the ACS 
for a view. Instead of Depth Lock, you now can enable ACS Plane Snap to force unsnapped points 
to fall on the plane of the ACS.
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Change Attributes Enhancements

Enhancements to the Change Attributes tool make it easier to select attributes from an existing 
element to apply to another.

Match element attributes by selection 

• The Change Attributes tool now has an option to match the element attributes in the tool settings 
to those of a selected element in the model.

Change Entire Element option 

• If on  the attributes for the entire element are changed
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• If on, the attributes for the entire element are changed.

• For example, where you want to change the color for a text style to green, where the existing 
text color is red and the underline color blue. If Change Entire Element is off, only the text will 
change color. If Change Entire Element is on, both the text and the underline will change to the 
new color.
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Color Enhancements

The following color books are provided in this edition:

• Natural Color Systems® (NCS)

• PANTONE® Goe
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Detailing Symbols Enhancements
In the past, detailing symbols were controlled by the Detailing Symbols Settings dialog (Element > 
Detailing Symbols Settings). In this release, Detailing Symbols are now controlled by styles. The new 
Detailing Symbol Styles dialog replaces the Detailing Symbols Settings dialog (Element > Detailing 
Symbol Styles). This allows you to better control the level, symbology and use of cell bubbles, etc.

Some detailing symbol tools renamed 

• The following tools in the Detailing Symbols toolbox have been renamed:

• The Place Arrow Marker tool is now the Place Section Callout tool.

• The Place Detail Marker tool is now the Place Detail Callout tool.

• The Place Section Marker tool is now the Place Drawing Title tool.

Detailing symbol styles 

• Detailing Symbol styles allow an administrator to define standards via symbology settings and 
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placeholder fields that can be updated after placement (using the FIELD UPDATE key-in). The 
benefit to using these styles is that when you change a setting in the style, the change is 
propagated to all detailing symbols using that style.

Detailing symbols integrated with dynamic views 

• When you create a section callout, you have the option of creating the corresponding saved view 
of the section in the design model. 

• When saved views are added to a sheet, existing section callouts that have empty fields are 
updated with relevant information. A link between the section callout and the drawing title is 
created so you can easily navigate between sheets.

Detailing symbols integrated with saved views
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Dynamic Views

Dynamic Views is a general name that encompasses several related technologies which share a 
common goal of making model analysis and documentation more interactive and intuitive. One of 
these technologies allows clipping of models and generating section graphics on the fly. Section 
views, detail views, and elevation views are types of dynamic views. 

Gone are the days when MicroStation designs were just static views, replaced by the ability to create 
live, intelligent sections of a design composition that update automatically (through the use of 
detailing symbols with smart fields and links) as the design evolves.

For more information on dynamic views, see the Drawing Composition Workflow.
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Dynamic Views

Create dynamic views from detailing symbols 

• You can create dynamic views when creating detailing symbols on sheets. These callouts allow 
you to create section views in your design composition that are linked to section callouts placed 
on sheets. Any modifications to the detailing symbol on the sheet are reflected in its 
corresponding saved view in the design model. Conversely, modifications to the saved view in the 
design model are also reflected in its associated detailing symbol on the sheet.

Control dynamic sections with detailing symbols 

• You can control a dynamic view using its edit handles. Select the view in the Saved Views dialog, 
turn on the Show column, and select the saved view box to see the clip volume edit handles. Any 
modifications made to the edit handles are reflected on all detailing symbols that are associated 
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to that view.

Attach dynamic view as references for model and sheet composition 

• You can attach a saved view as a reference on a sheet. The display settings and level masks of 
the saved view are used in the reference. If you move a detailing symbol associated with the 
saved view, it will change the saved view in the design model, and because the saved view was 
placed on a sheet, it will also change on the sheet. The power of dynamic views is that you can 
change the detailing symbol and have the reference update automatically.

Associate dimension to dynamic volumes and sections 

• Section graphics are graphics that are generated on the fly while displaying section views. The 
dimensioning tools are capable of creating dimensions associated to the section graphics.

• Additionally, the hatch pattern of a solid´s section graphics can be controlled by applying the 
relevant element template to the solid in the design model.
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Dynamic Views

Control display of dynamic volumes and section using display styles 

• The display of dynamic volumes and dynamic sections can be controlled using display styles. 
Display styles for these clippings can be applied by selecting a display style from the Clip Volume 
Settings area of the View Attributes dialog.

• Display styles can be selected from delivered styles or your can create new display styles on the 
Display Styles dialog.

Create dynamic views with clip volumes 
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• You can create a dynamic view by creating a clip volume and saving it in a saved view. To do so:

• Create a fitted section clip volume in a design model.

• Create a saved view using the new clip volume.

• Turn on the display of the saved view's boundary in the Saved Views dialog and select it to 
control its size, depth, and clipping.
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Format Interchange Enhancements
Format Interchange enhancements in this edition allow you to import and export files in additional 
formats. Exported file formats support Dynamic Views, another new feature. In addition, there are 
enhancements related to importing and referencing SKP files, and the supported raster file formats.

Dynamic view support for exported formats 

• If you print a dynamic view to 3D PDF, or if you export a dynamic view to a 3D export format 
such as SketchUp or OBJ, the results that you see will match the dynamic view. For example, you 
have a dynamic view that is divided by a section plane such that half of the model is transparent. 
When you print the dynamic view to 3D, the resulting PDF matches the dynamic view.

• Import OpenNurbs (Rhino 3DM) format 

• OpenNURBS (Non-Uniform Rational B-Splines) is an open source toolkit for reading and writing 
models in the 3DM format. It allows other applications to exchange 3D geometry data with Rhino 
3D software. As of this edition, you can import Rhino (3DM) files into MicroStation.
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• Use the OpenNurbs File Settings dialog to import a 3DM file.

• Import Google 3D Warehouse (SKP) version 6 format 

• In this edition you can read in SketchUp 6 files using the same methods that you used in 
previous editions of MicroStation. MicroStation continues to save them as SketchUp 5 files.

• Retain geographic coordinates during import and reference of Google 3D Warehouse 
(SKP) file format 

• If you have defined a Geographic Coordinate System in a model, you can:

• Attach SketchUp files that contain location information by using the Geographic–AEC Transform 
and Geographic Re-projected reference orientation modes.

• Automatically place SketchUp models that contain location information. After you select the 
model, a dialog appears in which you can confirm that you want to place the model by geo-
coordinates.
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Format Interchange Enhancements
Export OBJ file format 

• You can export to OBJ. OBJ is a lightweight 3D file format that supports mesh geometry and 
simple materials.

• The OBJ Export Settings dialog opens when you select File > Export > OBJ.

Export Maxwell Scene (MXS) file format 

• You can export MicroStation materials, geometry, and lighting settings to Maxwell Render and 
Maxwell Studio. The Maxwell Export Settings dialog is used to define the settings for exporting 
models to Maxwell Render or Maxwell Studio. It opens when you choose File > Export > Maxwell 
Scene, or when you key in MAXWELL SETTINGS. Exported files are saved as Maxwell Scene files 
with the extension MXS.

Export SVG file format 
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• You can export to SVG (Scalable Vector Graphics). SVG is a platform for 2D graphics. It has two 
parts: an XML-based file format and a programming API for graphical applications. Key features 
include shapes, text, and embedded raster graphics, with many different painting styles. It 
supports scripting through languages such as ECMAScript and has comprehensive support for 
animation.

• The Export SVG dialog opens when you select File > Export > SVG.

• You can view SVG graphics by using the Firefox or Internet Explorer browser with the free Adobe 
SVG plug-in.

Export Collada (DAE) format includes additional tag information 

• The Collada export process has been made fully compliant with the Collada 1.4.0 standard as 
implemented by Google Earth and Feeling Software´s ColladaMax/ColladaMaya plug-ins, including 
XML tags describing the geometry contained within the files. Files created from the MicroStation 
exporter may be incompatible with Collada viewers based on later standards.

• To export a file to Collada, select File > Export > Collada. The Create Collada File dialog opens. 
The default filename is that of the DGN file, but with a “.dae” extension.
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Format Interchange Enhancements

Open supported raster file formats directly 

• Now you can open raster files the same way that you open DGN files, using the File > Open 
menu item and using the File Open dialog.

• You cannot have more than one raster file open at a time. If you open a raster file when another 
one is already open, the first file closes. When a multi-page raster file is opened, all pages of the 
file are displayed side by side.

• Raster files always open as read–only.

• To change the filter, select Common Raster Formats or Common Geo Ref Raster Formats from 
the Files of type list.
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Geographic Coordinate System Support

MicroStation V8 Athens contains new Geo-Coordination features. These features let you specify the 
position of your design contents on the earth´s surface. Once that position is established, the design 
can be easily coordinated with other data for which the geographic location is known.

Apply geographic coordinate system from a coordinate system library 

• A geographic coordinate system (GCS) can be selected from an extensive library of predefined 
GCS’s. This is useful when you have already drawn data in a GCS and you want MicroStation to 
be aware of that GCS, or if you need to re-project data in a GCS to a different GCS. You can also 
use the library to designate the Geographic Coordinate System you intend to use for a new file.
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Apply geographic coordinate system from a source DGN file 

• The GCS used in a model of another design file can be used in your file, even if you don´t have 
the source file attached as a reference.

Apply geographic coordinate system from an attached reference file 

• A correctly oriented reference can be used to quickly select a GCS for your active model. The 
reference can have a standard GCS or a computed Azimuthal Equal Area GCS.

Apply master geographic coordinate system to attached reference files 

• A GCS can sometimes be assigned to directly attached references based on the GCS assigned to 
the current model.
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Geographic Coordinate System Support
Attach reference file using geographic coordinate system transform 

•When MicroStation is aware of the geographic location of the data in a model, geographically aware 
data can be conveniently referenced. MicroStation knows the location and orientation of both models 
and can calculate the coordinates of any point in the reference model in the master model.

Attach reference file using AEC coordinate system transform 

•The geo-referencing method Geographic – AEC Transform calculates the linear transform that gives 
the best approximation to the results you would get by performing the full re-projection algorithm. 
The approximation is acceptable for smaller scale data. The primary advantage of this geo-referencing 
method is that it gives the same performance as any other reference attachment since re-projection 
is not necessary.
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Set geographic coordinate system as ACS 

•When a geographic coordinate system is assigned to a model, that coordinate system appears in the 
Auxiliary Coordinate System dialog. When it is made the active Auxiliary Coordinate System, it is 
possible to enter data to MicroStation in Longitude, Latitude format, and you can set coordinate 
readout to show Longitude and Latitude.
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Geographic Coordinate System Support
Construct geographic coordinate system from Google Earth placemarks 

For users that use structure-centric coordinate systems, selecting a standard GCS from the Library is 
not possible. Instead, given some information about geographic positioning of your model, 
MicroStation can calculate an Azimuthal Equal Area GCS that will allow you to realize all the benefits 
of Geo-Coordination. You tell MicroStation about the geographic positioning of your design using 
Geographic Placemarks. A Placemark is a cell that contains text fields labeled Name:, Longitude:, 
Latitude:, and Altitude:. The longitude, latitude, and altitude fields specify the geographic position 
relative to the WGS 84 datum, which is the datum reported by GPS devices and also used by Google 
Earth. The corresponding position in the design file is specified by placement point of the cell. The 
scale and rotation of the cell does not affect its meaning as a Geographic Placemark.

Support for multiple geographic coordinate system libraries 
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•Multiple geographic coordinate system libraries can be used to choose a GCS.

Edit Re-projection Settings 

•You can re-project design data from one geographic coordinate system to another. This can be done 
either permanently or temporarily depending on if the GCS came from a model or a referenced model.
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Global Origin Enhancements

A new Global Origin dialog displays when you key in GO= or ACTIVE ORIGIN. Its two options let you 
define coordinates for a monument point, to relocate the global origin, or you can set it back to the 
default position at the center of the design plane.

Global origin settings by monument point 

• The Monument Point option for Mode, in the Global Origin dialog, lets you input values for x, y, 
and z (for 3D), which are located at the monument point that you select in the model.

Global origin settings by design plane center 
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Global Positioning System Device Support

MicroStation contains an interface to Global Positioning System (GPS) devices. The Global Positioning 
System consists of a constellation of satellites in earth's orbit that broadcast radio-navigation signals 
from which GPS devices can calculate reliable positions on a cost-free, continuous, worldwide basis. 
Please refer to http://www.gps.gov/ for more information.

Track GPS position in MicroStation 

• The Track tool displays the specified cell at the geographic location within the current model. 
Since the location within the model can be determined only if there is a geographic coordinate 
system assigned, the tool is disabled if there is no GCS. 
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Create line string based on GPS device input 

• The Trail tool places a line string along the track of the GPS device as it moves.

Place data point based on GPS device input 

• The Data Point at GPS Position tool places a data point in MicroStation at the current GPS 
position.

Center View based on GPS device input 

• The Center View at GPS Position tool centers the current view at the current GPS position.
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Graphics Display Enhancements
A display style consists of a render mode and optional settings and overrides that you can specify. 
Display styles are created and managed in the Display Styles dialog. Additional display modes are 
provided by default.

Display styles 

• Whereas in previous editions, on a per-view basis, you applied a view display mode with 
companion settings, in this edition you can apply a display style that encompasses both the 
render mode and the settings, plus optional overrides.

• Display styles are typically saved as shared resources in DGN libraries.

Display style options 

• In addition to a render mode — Wireframe, Hidden Line, Filled Hidden Line, or Shaded — a 
display style also specifies optional settings and overrides.

h di l l f i d i d d i i
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Set the display style of views, saved views, and dynamic views 

• Display styles apply to saved and dynamic views as well as normal views.

Create, copy, and delete display styles 

• The Display Styles dialog (Settings > Display Styles) contains tools for managing display styles.

• These tools work the same as those in other dialogs that contain tools for managing styles, such 
as the Dimension Styles dialog.

Standard display styles 

• There are some standard display styles that are always available for selection. These styles 
cannot be deleted. 

Improved hidden line display mode 

• You can change the following settings and overrides for the hidden line render mode. None are 
set by default.
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Levels Enhancements

Enhancements to the Level Manager include ways to simplify the use and manipulation of levels and 
level numbers.

Right-click jump to active level in Level Manager 

• This feature allows you to jump to the active level in the Level Manager and the Level Display 
dialogs. The Jump to Active Level item has been added to the right–click menu from the right 
pane of the Level Manager dialog and to the lower pane of the Level Display dialog. This is 
particularly useful when working with a large number of levels because it eliminates the need to 
scroll through the level list to find the active level. 
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Auto(System)–generated verses user-assigned level numbers 
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Models Enhancements

The enhancements to Models include additional viewing capabilities, Project Explorer integration with the 
Models dialog, and sheet name display in the Models dialog.

View different models from the same file in each view 

• You can view more than one model from the same file in separate views. In the example below, notice 
that the “Multi-models View” view was created and the titles of the two views match two separate models 
in the Models dialog.

Project Explorer integration in Models dialog 
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• An icon has been added to the Model Manager dialog. The icon puts the dialog into one of two modes:

• Active File Mode — Shows the current source of the models. If set to Active File, the models are in the 
master file. If set to Link Set, the models are in Project Explorer.

• Link Set Mode — Shows a Project Explorer layout, allowing you to select an active file or folder from the 
active project in Project Explorer.

Models dialog displays the sheet name 

• The Sheet Name column has been added to the Models dialog in support of sheet sequencing. The sheet 
name should match the corresponding sheet link name in Project Explorer. If the two get out of sequence 
(that is, the sheet link name was changed in Project Explorer or in the Model Properties in the Model 
dialog), the new sheet name can either be pushed out from Project Explorer to the model or pulled from 
the model back to Project Explorer so they are synchronized.
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Named Expressions

You can define named expressions to retrieve values from application data structures and properties 
of application data, such as files, models, and elements. Within a named expression, arithmetical 
operations and comparison and conditional tests can be applied to retrieved values.

• When a named expression is evaluated by the product's evaluator, the result is a string, numeric, 
or Boolean value.

• The potential exists to use named expressions in many different ways.

• In this edition you can use named expressions with the Customize utility to
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• define rules to control when a tool is available.

• define rules to control when a task is available.

• define rules for right-click context menus, such as conditions under which a context menu item is 
hidden.

• Named expressions are stored in DGN libraries. If a DGNLib contains named expressions it must 
be stored in the location indicated by the MS_DGNLIBLIST configuration variable.

• Named expressions are defined in the Named Expressions dialog (Utilities > Named Expressions).

32 | WWW.BENTLEY.COM

Printing Enhancements

Print Organizer is a utility for creating, managing, and publishing project deliverables and is a 
replacement for the Batch Print utility. Additional Printing enhancements include changes in the Print 
dialog for single sheet printing.

Print Organizer 

• Print Organizer stores project deliverables in a print set file with a .pset extension. These project 
deliverables are represented as a set of hierarchically organized print definitions grouped by 
folders. Each print definition consists of a reference to a DGN file to be published, like a sheet 
model in a DGN file, along with properties, such as size, scale, and form name that determine 
how the DGN file will be published within the print set.

• Unlike the Batch Print utility, Print Organizer supports the following features: composing print 
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sets interactively by dragging and dropping files from Windows Explorer, print preview, individual 
print definition settings, hierarchical organized print sets, print definition multi-edit, in-place 
editing, PDF output that preserves the hierarchy defined in the print set, Project Explorer 
integration, and print styles.

• The following sections discuss the features of Print Organizer.

Hierarchical organized print sets 

• Print Organizer allows you to define hierarchical organized print sets that best reflect the ordering 
of their published output. Print sets consist of a collection of print definitions and folders. Print 
definitions can be organized inside folders, with intermingled sub-folders and print definitions 
inside each folder. Print Organizer preserves the hierarchy defined in the print set when 
publishing PDF documents.

• For more information on hierarchical organized print sets, see Working with Print Sets.
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Printing Enhancements

Individual print definition settings 

• Print Organizer allows you to individually set print preferences per item as opposed to Batch 
Print's existing per set attributes. Each print definition consists of a reference to a DGN file to be 
published, like a sheet model in a DGN file, along with properties, like size, scale, and form name 
that determine how the DGN file will be published within the print set. Having per print definition 
print settings allows you to specify a different pen table or print area for each print definition in 
the print set.

Print definition multi-edit 

• Print Organizer allows you to edit the properties of individual or groups of print definitions. 
Depending on the number of print definitions selected, Print Organizer displays one of two forms 
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of a Properties dialog: single-edit if one print definition is selected, multi-edit if multiple print 
definitions are selected.

• The single-edit Properties dialog displays detailed information about the selected print definition 
and allows you to edit the displayed information. As you change print definition property values, 
related property values also change.

• Unlike the single-edit Properties dialog, the multi-edit Modify Properties dialog does not display 
any information about the selected print definitions. Instead, it operates as a fill-in-the-blanks 
form. Any properties you specify are applied to each of the selected print definitions when you 
click OK to dismiss the dialog.

• Multi-edit Modify Properties dialog
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Printing Enhancements
• Print styles 

• Print Styles allow you to define and reuse named collections of print definition properties. Print 
Styles are created using Print Organizer's Define Print Styles option on the Tools menu, and are 
stored in the open DGN file or in the configured DGN libraries. Print Styles are applied using Print 
Organizer or the Print dialog.

• Print Styles are useful if you frequently use the same print definition properties every time you 
print. For example, if you always print at a particular size with a specific pen table, you can 
define those print definition properties in a Print Style and have them automatically applied to a 
print set. This is accomplished by identifying a print style as a default print style or by assigning a 
print style to a printer driver configuration file. 

• You can also store groups of commonly used print definition properties in a Print Style and then 
reference them on demand. This method of referencing print styles is helpful when you use a 
group of print definition properties for a specific project or on an occasional basis
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group of print definition properties for a specific project or on an occasional basis.

• Project Explorer integration 

• Using Project Explorer with Print Organizer, you can view, print, compose, and navigate print 
sets.

• Named expressions support 

• Print Organizer supports named expressions for print definition and output file names. Named 
expressions are created using the product's Named Expressions dialog and are stored in the 
configured DGN libraries. Once the named expressions are defined, they are visible in the 
appropriate Print Organizer dialogs. Print Organizer also supports custom expressions and 
predefined expressions for print definition and output file names.
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Printing Enhancements
PDF output with hierarchical bookmarks 

• Print Organizer allows you to create PDF output that preserves the hierarchy defined in the 
originating print set. This is accomplished by editing the Enable Bookmark Hierarchy property in 
the pdf.pltcfg printer driver configuration file. 

• This printer driver configuration property has no affect on PDF files created from the interactive 
Print dialog or Batch Print. It is applicable to Print Organizer, and only relevant for print sets 
containing folders.

Print preview 

• Print Organizer allows you to preview prints of individual print definitions. Selecting File > Print 
Preview opens a resizable Preview window, which lets you preview the drawing(s) prior to 
printing. Options are available to select an individual print definition to preview, or to preview the 
next or previous print definition in the print definition list box. 
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In-place print definition editing and set composition 

• Print Organizer allows you to edit print definitions in place and compose print sets interactively 
through operations like drag and drop.

• Composing a print set is as easy as dragging and dropping design files from Windows Explorer 
into Print Organizer. You can drop the design files into specific folders to hierarchically group your 
project deliverables. If you prefer not to use the drag and drop feature to create a print set, you 
can use Print Organizer's Add Files to Set menu item to add design files to a print set. To 
hierarchically group your print definitions, you can create folders using the Add Folder menu item 
prior to adding the design files. 

• Print Organizer's right pane displays print definitions in tabular form, where each row is a print 
definition and each column is a print definition property. Using Print Organizer's in-place editing 
feature, you can edit individual properties for one or more print definitions. Select the print 
definition(s) and double-click on the property in a specific column such as scale, rotation, or units 
to specify the new property value. Some properties require you to type in the property value 
while others display a drop-down list box you can choose from.
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Printing Enhancements
Print Set File (PSET) 

• Print Organizer authors print set (.pset) files as a container for print definitions, folders that 
group print definitions, and global set information pertaining to the print set. Each print definition 
consists of a reference to a design file to be published, like a sheet model in a design file, along 
with properties, such as size, scale, and form name that determine how the design file will be 
published within the print set.

• The Print dialog's Save Print Definition File item on the File menu also allows you to save a print 
set file that can be opened by Print Organizer. This print set file contains a single print definition 
of the active design file. 

Replaces Batch Print functionality 

• Print Organizer provides a seamless upgrade for Batch Print users. Legacy data created for the 
Batch Print utility such as pen tables and job set files are supported in Print Organizer. 

P i t O i '  Fil   O   it     i t t ( t) fil    j b t ( j b) fil  
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• Print Organizer's File > Open menu item can open a print set (.pset) file or a job set (.job) file. 
When Print Organizer opens a job set file, each corresponding model in the job set is converted 
to a print definition. The print definition properties are obtained from the print specifications 
stored in Batch Print's batchplt.spc file. 

• After a job set file is imported into Print Organizer, you can apply a print style, use the multi-edit 
feature, or in-place editing to individually set print preferences per item as opposed to Batch 
Print's existing per set attributes. 

• Print Organizer cannot save to a job set file.

Single Sheet Printing 

• Enhancements have been made to the Print dialog for single sheet printing. These enhancements 
include several new print configuration variables, additional print attributes, a revised Print-
Preferences dialog, and changes to printer driver configuration files.

Plot files migrated from PLT to PLTCFG 

• The product only delivers default .pltcfg printer driver configuration files into the "System\pltcfg" 
directory. Existing .plt files are still supported, but they are no longer delivered.
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Printing Enhancements
Print Definition files 

• Print definition files have replaced print setup or print configuration text (.ini) files. A print definition 
(.pset) file is a binary file and has the same file format as Print Organizer's print set file, but it contains 
only a single print definition. Print definition files are not intended to be edited outside of MicroStation.

• The Configuration pull-down menu on the Print dialog, with its Open, Save, and Save As items, has been 
removed. The menu has been replaced with Open Print Definition File and Save Print Definition File items 
under the File menu.

• The Open Print Definition File menu item brings up the Select Print Definition File dialog that allows you to 
select a print definition file whose extension may be either ".pset" or ".ini". An .ini file is a legacy print 
configuration file format. A .pset file is the Print Organizer print set file format. The Print dialog can read 
both .ini and .pset files, but can write only .pset files.

Default TIFF monochrome compression is RLE 

• If you are using the TIFF printer driver (tiff.pltcfg) to produce a print and the Color mode is set to 
h h d f l h h d f ll f
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Monochrome, the default compression type has changed from CCITG4 to RLE. You can still specify CCITG4 
by editing the printer driver configuration file’s driver properties.

Revised Print dialog preferences 

• The collection of controls on the Print-Preferences dialog has changed. The Honor sheet definition 
preference has been removed, since sheet definition boundaries are now always recognized by the Print 
dialog. 

• The following preferences were changed from global preferences to print attributes and appear on the 
Print Attributes dialog: Apply print color mode to raster and Use view background color when rendering.

Additional print attributes 

• The collection of controls on the Print Attributes dialog has changed. The following attributes have been 
added: Points, Apply print color mode to raster, and Use view background color when rendering.
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Printing Enhancements
Non-rasterized Hidden Line Removal 

• You can now print a view with hidden line display in non-rasterized mode. Previously the 
presence of a hidden line view would set and disable the Rasterized check box, causing the print 
to be submitted as raster data. 

• There is also a new menu item on the Print dialog's Settings menu for Hidden Line Removal. The 
new Hidden Line Removal Settings dialog allows you to control settings that affect the hidden line 
removal process.

Print configuration variables 

• The following configuration variables have been added to the printing system. These 
configuration variables apply to both Print Organizer and the Print dialog. They are:

• MS_PRINTDEF_PATH — specifies the search path for print definition (.pset or .ini) files. This 
variable replaces MS_PLOTINI, which is no longer supported.
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• MS_PLTCFG_PATH — specifies the search path for printer driver configuration (.pltcfg or .plt) 
files. 

• Previously, the MS_PLTR configuration variable was used to specify the initial print driver 
configuration file, if the most recently used value was undefined. The MS_PLTR configuration 
variable is now read-only and used solely for print accounting purposes.

• MS_DEFAULT_PLTCFG_FILE — specifies a default printer driver configuration file. If the 
configuration variable MS_DEFAULT_PLTCFG_FILE is set to a printer driver configuration 
filename, that file (instead of the most recently used one) is selected when you open the print 
dialog.

• The MS_PLTFILES configuration variable behavior has changed. The print output directory 
specified by the MS_PLTFILES configuration variable is now given priority over the most recently 
used print output directory. If this configuration variable is defined, the most recently used 
directory is always ignored when the Print dialog brings up the Save Print As dialog for saving a 
print output file.
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Project Explorer and Link Set Update

Project Explorer provides hierarchical storage for information related to design such as DGN and DWG 
files, models, references, Adobe PDFs, Microsoft Word documents, Microsoft Excel workbooks, and 
their contents. The Model Manager dialog serves the purpose of managing models in the master file. 
It is convenient for you to be able to list models hierarchically stored in the active project in the 
Project Explorer dialog.

Additional link types for Project Explorer 

• Three link types have been added to the Project Explorer.

Link to another link set 
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• You can create a link to a link set by clicking the Create Link icon in the Project Explorer dialog
and selecting LinkSet Link. This opens the Create Link dialog where you can select the link set to 
be linked using the Select LinkSet icon. 

• In the Project Explorer dialog, you can create a copy of a link set or link folder by holding down 
the <Ctrl> key and dragging the selected link set or link folder to a new location. This is the 
same as right-clicking the link set or link folder, then performing the copy and paste functions.
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Project Explorer and Link Set Update
Link to external folder 

• You can create a link (link type of Folder Link) to a physical folder containing DGN, DWG, DXF or 
other files. Folders can be dragged from Windows Explorer directly in the Project Explorer dialog 
or created via the PROJECT CREATE LINK FOLDER [folder-path] key-in to a folder containing 
DGN, DWG, DXF or other files. Multiple folder paths can be specified via this key-in.

• If you create a link to a folder, in the Project Explorer dialog you will see the name of the folder 
in black, indicating you can copy or delete the folder and all the files and sub-folders within the 
folders. The files and sub-folders under the folder cannot be moved or deleted independently.

• Right-click the linked folder in Project Explorer and choose Open from the pop-up to open 
Windows Explorer at the location of the linked folder.
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Link to configuration variable 

• You can create a link to a configuration variable (such as MS_CELLLIST or MS_DGNLIBLIST) by 
clicking the Create Link icon in the Project Explorer dialog and selecting Configuration Variable 
Link. This opens the Create Configuration Variable Link dialog where you can set up the 
configuration variable to be linked.

Harvested folders (link to configuration variable with filtering) 

• A harvested folder displays models or named views that are contained in a set of files. Using 
harvested folders, you can keep track of sheets and views, because the folders are an up-to-date 
view of what is actually in the files. MicroStation generates the contents of a harvested folder by 
searching for specified resources within a set of files. When resources are added, removed, or 
renamed, harvested folders can be refreshed to reflect the changes. Several pre-defined 
harvested folders are delivered with MicroStation, including folders to display sheet models and 
several types of saved views.
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Raster Manager Enhancements
The changes and enhancements in Raster Manager are designed to improve the performance of 
Raster Manager's attachment and manipulation tools and options.

Attach raster from Web Map Servers 

• You can now attach raster files from a WMS Map Server.

Configure raster display to utilize independent process 

• Display rasters using a process independent of other MicroStation operations. Any new raster 
display request will interrupt the previous request, and start the new one. Therefore if the user 
executes multiple zoom-in operations, only the last operation will be completely processed. The 
full resolution data will then display as it becomes available. Choose this setting in the 
Preferences dialog Raster Manager category.

Geographic coordinate system support 

• Raster Manager supports the coordinate system defined in MicroStation  It is now possible to 
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• Raster Manager supports the coordinate system defined in MicroStation. It is now possible to 
display rasters on-the-fly from one coordinate system to another. See the Raster Manager dialog
for information about the assigned coordinate system. 

Drape raster images 

• Raster Manager no longer needs Descartes to drape rasters over a digital elevation model. See 
the section called for further details. 

iTiff64 format support 

• Raster Manager now supports the iTiff64 file type. This new file format can now support raster 
files larger than 4 GB.

Configuration variables for IMG files 

• Two configuration variables have been added for working with IMG files.

• MS_RASTER_IMG_CHANNELS — Sets the band number to use for Red, Green, Blue and Alpha 
channels when a file whose format is IMG is attached. 

• MS_RASTER_IMG_STRETCH — Sets the band number to use for Red, Green, Blue and Alpha 
channels when a file whose format is IMG is attached. 
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References Enhancements
A major enhancement to references is the ability to edit a reference from within the active model. In 
addition, the active model's annotation scale applies to annotations in references.

Activate Reference for in-place editing 

• A new capability lets you edit a reference in-place. That is, you can edit a reference from within 
the active model. To do this you first must activate the reference. 

• When a reference is activated:

• Only operations on the activated reference are permitted.

• By default, all elements in references above the activated reference in the file hierarchy, as well 
as the active model, are displayed with an override color. You can control whether or not an 
override color is used, and what the color is.

• If you activate another reference, the currently activated reference is automatically deactivated.

© 2008 Bentley Systems, Incorporated

• The reference is locked so that it cannot be edited in another session.

• DGN library data, such as levels and level filters, is not available in an activated reference file.

References support active model annotation scale 

• In the past you may have added annotations to design models that are referenced into sheets. 
You also may have added annotations directly on the sheet. If the annotations were too small, 
you would have changed the model's annotation scale, but that would have affected only the 
annotations directly on the sheet. The annotations in the reference were not changed. Therefore, 
the only way you could change the annotations was to exchange into the reference and scale 
them.

• Now the active model's annotation scale applies to annotations in references, too. If you change 
the scale of the annotations on the sheet, the scale of the annotations in the references changes 
as well.

• To make a reference's annotations use the active model's annotation scale, you must turn on this 
option. In the References dialog there is a new column named Use Active Annotation Scale
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Reference Enhancements

Detail scale 

• Detail scale helps you represent the Master:Ref scale in terms of the sheet scale. For example, if 
your sheet scale (annotation scale) is 1/8” = 1´ and you want to place a detail reference of scale 
1/4” = 1´, simply pick the new scale from the Detail Scale combo box. It automatically computes 
the Master:Ref scale as 2:1.

Synchronize with saved view 

• When you attach a saved view, you can specify that the display of the reference should always be 
synchronized with the original saved view. In the Reference Attachment Settings dialog, turn on 
the Synchronize with Saved View check box.

• In order to change the appearance of a reference, you have to modify the saved view that it is 
synchronized with  This is to ensure fidelity of display properties such as view attributes  level 
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synchronized with. This is to ensure fidelity of display properties such as view attributes, level 
masks, clip volume, display styles and others.

Drawing title 

• When attaching a reference on a sheet, you can optionally create a drawing title. A drawing title 
describes a drawing on a sheet. If there are four references on a sheet (top, front, right, and 
isometric), you create four drawing titles to demarcate the four references. It plays a crucial role 
in automatically linking call-outs across sheets. Properties such as Name, Detail Scale, and 
Identifier are displayed in the call-outs in the form of fields.
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Selection Enhancements

Enhancements to selection include additional options on the Element Selection tool and drag support 
on the manipulation tools.

Expanded Element Selection criteria 

• Five attributes tabs, hidden by default, are added to the Element Selection tool. To display one or 
all of these tabs, right-click on the attributes section of the tool settings window. From the menu 
that opens, turn on the desired attributes.

Text Styles 

• You can select the required text style from a list.

Dimension Styles 

© 2008 Bentley Systems, Incorporated

y

• You can select the required dimension style from a list.

Multi-line Styles 

• You can select the required multi-line style from a list.

Transparency 

• You can select the required transparency from a list.

Display Priority 

• You can select the display priority from a list.

Drag selection support during manipulate commands 

• Selecting elements for a manipulation now supports drag selection. 

• After selecting a manipulation tool, you can now select multiple elements by dragging a window 
around them.
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Sheet Composition Enhancements
Enhancements in this area allow you to create sheet models more easily and to manipulate their 
boundaries.

Drawing Composition workflow task 

• The Drawing Composition tools have been reorganized in a Drawing Composition workflow task, 
which appears in the Tasks dialog. This workflow is made up of tasks organized in a logical order 
for working with drawing composition and dynamic views. Open the Drawing Composition 
workflow task by clicking its tab.

• The Drawing Composition tools are organized in the following tasks. Open each task by clicking 
its tab.

• Organize — Contains tools for opening Project Explorer and link sets.

• Drawing — Contains the tools from the Drawing task.

• Design Composition — Contains tools for creating models and working with references.
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• Create Views (2D) — Contains tools for working with clip volumes, levels, view attributes, and 
saved views.

• Create Views (3D) — Contains tools for working with levels, view attributes, saved views, placing 
fitted sections, and changing views.

• Sheet Composition — Contains tools for creating sheet models, defining sheet boundaries, and 
working with references.

• Annotate — Contains tools for base geometry, measuring, patterning, dimensioning, detailing 
symbols, text, and project navigation.

Manipulate the Sheet Boundary 

• The Define Sheet Boundary tool replaces the Define Sheet Layout tool. You access this tool from 
the Sheet Composition toolbox or by clicking its icon in the Models dialog.

• Define Sheet Boundary tool

• Clicking this tool opens the Sheet Boundary tool settings window. The tool controls the Sheet 
Scale (Annotation Scale) and the Border Attachment.
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Task Navigation Enhancements
The Tasks dialog has been updated to allow you to work with tasks and tools more easily.

Integrated Main tools in Tasks dialog 

• Tools from the Main toolbox have been integrated into the Tasks dialog in a Main task. In the 
default setup, the Main task appears at the top of the dialog.

• You can remove the Main task from the Tasks dialog by clearing the Show Main Task Tools check 
box in the Task Navigation section of the Preferences dialog. You also can customize the Main 
task that appears at the top your tasks.

• As in previous editions, these tools appear in the Main toolbox, which you can show and hide by 
selecting Tools > Main.

Work flows 

• A work flow can consist of one or more tasks. In most cases a work flow consists of a collection of 
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tasks organized in the order that you will use them to complete a project or job. Each task 
contains the tools you need to complete the task. The Drawing Composition work flow is 
delivered with MicroStation.

• In order to create a work flow you must:

• Create and store it in a DGN library (a file with the extension .DGNLIB)

• Make sure that the .DGNLIB file is stored with the configured DGN library files, that is, in the 
location specified by the MS_GUIDGNLIBLIST configuration variable.

• Work flows are created and managed the same way as tasks, on the Tasks tab in the Customize 
dialog. The only difference is that a work flow's Treat Task as Workflow property is set to True 
and it has a different icon.

• Once created, work flows appear in the Tasks dialog. You can open a work flow in a separate 
instance of the Tasks dialog.
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Task Navigation Enhancements
Include tasks within tasks 

• You can create one instance of a task and reference it in other tasks. If you need to change the 
task, you change it in one location.

• Referenced tasks are updated automatically when you change the original task.

• When you select a referenced task, the Task Path in the Properties pane indicates the location of 
the original task.

• Referenced tasks can be cut, copied, deleted, moved up or down, but they cannot be modified or 
renamed.

• Referenced tasks have a Task icon with a small arrow on it.

• In order to reference a task in another task you must:

• Create and store the task in a DGN library (a file with the extension DGNLIB)
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• Create and store the task in a DGN library (a file with the extension .DGNLIB)

• Make sure that the .DGNLIB file is stored with the configured DGN library files, that is, in the 
location specified by the MS_GUIDGNLIBLIST configuration variable.

• Task references are created in the Customize dialog on the Tasks tab.

Each task can define a customized Main task 

• When creating tasks you can customize the Main task that appears at the top of the Tasks dialog 
when your task is selected. You do this in the Customize dialog on the Main Tasks tab.

• In order to customize the Main task for a task:

• Create and store the task in a DGN library (a file with the extension .DGNLIB)

• Make sure that the .DGNLIB file is stored with the configured DGN library files, that is, in the 
location specified by the MS_GUIDGNLIBLIST configuration variable.

• Add the Main task in the Customize dialog.

• Assign the Main task to a task.
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Text Enhancements
Text enhancements include a placeholder field and the ability to change case by a selection set or 
fence. The Text Styles dialog now allows for distances relative to text height and multi-select to edit 
styles. The Advanced tab of the Text Styles dialog uses a property pane format and allows for 
comparisons between styles. Word Processor updates include an insert field, subscript and superscript 
icons and right-click operation to change the case. The Edit Text tool retains its text settings and the 
Find/Replace Text tool supports data fields.

Placeholder fields 

• A placeholder field is a field placed in a model as target for future population. This target displays 
as the field name until a value is provided via a link.

• Placeholder fields are generally one of three types:

• Fields pointing to the properties of a parent cell

• Fields pointing to the properties of a parent Digital Signature cell
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Fields pointing to the properties of a parent Digital Signature cell

• Fields pointing to the properties of a link target attached to a parent cell

• The Insert Field functionality has been enhanced to accommodate placeholder fields. The Field 
Type Picker dialog has been added allowing you to select the type of field being created.

• Three new field types (Place Holder Cell Properties, Place Holder Link Properties, and Place Holder 
Digital Signature Cell Properties) have been added to the previously existing types (Element 
Properties, Model Properties, and File Properties).

• The Field Type dialog has two entry points from the Text Editor — Word Processor dialog; 
selecting Insert Field from the right–click menu (previously existing entry point) or the new icon. 

Change Case by selection set or fence 

• This tool is used to change the case of a piece of text. Case change options include Upper Case, 
Lower Case, Title Case, and First Capital. This tool also supports text selection via a fence.
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Text Enhancements
Text Style dialog enhancements 

Distances relative to text height 

• Distances (used for spacing and/or backgrounds, for example) are now relative to text height. 
This behavior is similar to how the Dimension Styles dialog works. In the past, these distances 
were an absolute value in master units. If the text height changed dramatically, the spacing 
could become inappropriate. Now, if the text height changes, the spacing adjusts relative to the 
change in the text height.

Multi-select to edit styles 

• You can now edit properties of multiple styles at the same time and the changes are propagated 
through all the selected styles. When selecting multiple styles for edit, the properties of the last 
selected style display. If there are differences in properties in the selected styles, the titles of 
those properties appear in bold. If these properties are changed so they match in all the selected 
t l  th  b ld i  d
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styles, the bold is removed.

• Property names are blue if the modification to the property is different then what is in use in the 
file.

Property pane on Advanced tab 

• The Advanced tab of the Text Style dialog now uses a property pane style format. This was done 
to improve functionality, reliability and consistency with the Dimension Styles.

Advanced tab allows comparison between styles 

• Two new modes (Comparison and Differences) have been added to the Advanced tab of the Text 
Styles dialog. Comparison mode shows a side by side comparison of the properties of two 
selected text styles. Differences mode shows the differences of the properties of two selected text 
styles.

• Text Styles dialog in Comparison mode

• Text Styles dialog in Differences mode
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Text Enhancements
Word Processor enhancements 

Insert Field, Subscript, and Superscript icons 

• Three new icons have been added to the Text Editor — Word Processor dialog.

• The Insert Field icon opens the new Field Type Picker dialog, used to select the type of field to be created. See 
Placeholder fields for more information.

• The Superscript and Subscript icons

Right-click to change case 

• The Change Case > Upper Case and Change Case > Lower Case menu items have been added to the right-click 
menu of the Text Editor — Word Processor dialog.

Font Enhancements 

• Two changes have been made to the way fonts are handled.

Font configuration file 
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Font configuration file 

• MstnFontConfig.xml, an XML-based configuration file, is used for the handling of fonts. This file has two 
sections: language-based font specifications and font details, and can be modified with any text or XML editor. 
The file is installed in …\Workspace\System\fonts.

Font configuration variables 

• Three new font-related configuration variables have been added for specifying names for files and directories.

Edit Text tool retains text settings 

• In the past, the Edit Text tool would change the active settings whenever you edited a piece of text. This 
behavior has been changed so settings revert to the previous settings when the Edit Text tool is closed. This 
change affects the active settings only and not the text styles.

Find/Replace Text supports data fields 

• The Find/Replace Text tool can now find and replace text in enter data fields.

ISOREC font #27 added 

• The ISOREC font #27 from the AUSfont library has been added in this edition. It is an ISO standard font.
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Text Enhancements
Text enhancements include a placeholder field and the ability to change case by a selection set or 
fence. The Text Styles dialog now allows for distances relative to text height and multi-select to edit 
styles. The Advanced tab of the Text Styles dialog uses a property pane format and allows for 
comparisons between styles. Word Processor updates include an insert field, subscript and superscript 
icons and right-click operation to change the case. The Edit Text tool retains its text settings and the 
Find/Replace Text tool supports data fields.

Placeholder fields 

• A placeholder field is a field placed in a model as target for future population. This target displays 
as the field name until a value is provided via a link.

• Placeholder fields are generally one of three types:

• Fields pointing to the properties of a parent cell

• Fields pointing to the properties of a parent Digital Signature cell
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Fields pointing to the properties of a parent Digital Signature cell

• Fields pointing to the properties of a link target attached to a parent cell

• The Insert Field functionality has been enhanced to accommodate placeholder fields. The Field 
Type Picker dialog has been added allowing you to select the type of field being created.

• Three new field types (Place Holder Cell Properties, Place Holder Link Properties, and Place Holder 
Digital Signature Cell Properties) have been added to the previously existing types (Element 
Properties, Model Properties, and File Properties).

• The Field Type dialog has two entry points from the Text Editor — Word Processor dialog; 
selecting Insert Field from the right–click menu (previously existing entry point) or the new icon. 

Change Case by selection set or fence 

• This tool is used to change the case of a piece of text. Case change options include Upper Case, 
Lower Case, Title Case, and First Capital. This tool also supports text selection via a fence.
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User Interface Enhancements
The addition of drag and drop support, the ability to customize right-click menus and the Tasks 
dialog, and three new ways to customize the status bar make the interface easier to use.

Drag and drop support 

• The ability to drag and drop between dialogs and view windows provides an easy method to 
construct a design composition for references or a sheet composition of drawing titles. There are 
many different options for dragging and dropping models, links, saved views and references. The 
Models and Saved Views dialogs can now look outside the active model, allowing you to organize 
sets of models or saved views and access them for design and/or sheet composition.

• Some of the possible drag and drop operations are:

• Drag and drop models from the Models dialog to the Project Explorer dialog

• Drag and drop a saved view from the Saved Views dialog to the Project Explorer dialog

D  d d  fil  d f ld  f  Wi d  E l  t  th  P j t E l  di l
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• Drag and drop files and folders from Windows Explorer to the Project Explorer dialog

• Drag and drop links from the Project Explorer dialog to a view window

• Drag and drop links within the Project Explorer dialog

• Drag and drop saved views from the Saved Views dialog to a view window

• Drag and drop models from the Models dialog to a view window

• Drag and drop DGN, DWG, and DGNLIB files from Windows Explorer to the Saved Views dialog

• When dragging and dropping a model, saved view, model link, or saved view link from the 
Models, Saved Views, or Project Explorer dialog, the corresponding model or saved view is 
attached to the active file. The Reference Settings dialog displays to allow for the adjustment of 
the annotation scale or other reference settings.

• One common use of the drag and drop feature is between the Models dialog and a view window.

• You can drag and drop a model into a view window and it is attached as a reference to the active 
design. If you press <Ctrl> and drag and drop a model into a view window, it is placed as a cell. 
If you press <Alt> and drag and drop a model into a view window, it is placed as a link on an 
element.
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User Interface Enhancements
Right-click context menus based on named expressions 

• When customizing right-click context menus and menu items (Workspace > Customize > Context 
Menus tab), you can show or hide and enable or disable them based on tests created in the 
Named Expressions dialog. For example, you can create a right-click menu that will be available 
only when you are working on a sheet model by setting the menu's Show/Hide Test property to 
“IsSheetModel” and its Enable/Disable Test property to “IsSheetModel”.

Show / hide support in Tasks dialog 

• Right-clicking a task in the Tasks dialog opens a menu that allows you to show or hide the 
following:

• Show/Hide Tools > (Tools' names) — Allows you to show or hide individual tools.

• Show/Hide Tools > Show All — Shows all of the tools.

© 2008 Bentley Systems, Incorporated

• Show/Hide Tools > List — Lists the tools in a dialog in which you can choose which to show or 
hide them.

Show / hide support in status bar 

• Right-clicking in the status bar opens a menu allowing you to show or hide sections of the status 
bar.

Coordinates display in status bar 

• Right-clicking in the Running Coordinates section of the status bar turns on the coordinates 
display. As you move your cursor, the coordinates of your current position display according to 
the active Tentative Point Mode. When you left-click, a menu displays six options. The Delta 
modes show the X, Y, and Z displacement from the last data point. The Distance modes show the 
distance and direction from the last data point.

Locks dialog 

• Left-clicking the Locks icon on the status bar and selecting Full on the popup menu opens the 
Locks dialog.
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User Interface Enhancements
MicroStation Manager is renamed

• The MicroStation Manager has been renamed to File Open
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User Preferences Enhancements
Preference options for the Raster Manager, Reference and View Options categories have been added.

Raster Manager 

• The following user preferences related to rasters can be set in the Preferences dialog.

Disable Delete Element tool on Selected Rasters 

• If on, the rasters in the selection set will not be deleted by the Delete Element tool.

Display Raster Using an Independent Process 

• If on, displays rasters using a process independent of other MicroStation operations. Any new 
request to display raster interrupts the previous request, and starts the new one. Therefore if the 
user executes multiple zoom-in operations, only the last operation will be completely processed. 
Also, the display engine uses any data already in memory to provide immediate display. The full 
resolution data then displays as it becomes available.
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Display Raster Border 

• Three new raster border display modes are available: 

• When Selected - The borders display only when the rasters are selected. 

• Never - The borders never display and users must look at the Raster Manager dialog to know 
which rasters are selected.

• Always - The borders of all rasters are always displayed. 

Manage memory usage for raster files 

• A new tab in the Raster Manager category of the Preferences dialog allows managing the memory 
usage. You can limit the memory usage to a certain percentage. You can also determine the 
raster load mode: 

• Automatic — Rasters are loaded in memory until the memory limit is reached, afterward the 
Standard mode is used.

• Standard — Cache files are created if required.

• RAM — Rasters are always loaded in memory (not recommended). 
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User Preferences Enhancements

Reference 

• A new option has been added to the Reference category of the Preferences dialog (Workspace > 
Preferences).

Control active reference override color 

• If this option is on, sets the override color of everything not in the active reference or nested to 
the active reference.

View Options 

• New options have been added to the View Options category of the Preferences dialog (Workspace 
> Preferences).

Design model background color 
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• This options allows you to set the color used as the design model background color.

Sheet model background color 

• This options allows you to set the color used as the sheet model background color.

Element highlight color override 

• This options allows you to set the color used to highlight the active element.

Selection set color override 

• This options allows you to set the color used to display the selection set.
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Views Enhancements
Saved views can now be displayed as a graphical element within design and sheet models. Once 
displayed, a saved view can be selected and manipulated like a standard element. The View Attributes 
dialog is enhanced and expanded to include sections for Presentation and Clip Volume Settings.

Manipulate saved view with modification tools 

• The Saved View dialog has a new column, Show. When Show is enabled for a saved view, 
graphics display its view parameters. In any view, the saved view graphics can be selected with 
the Selection tool, or by a fence, and manipulated like a standard element.

To modify a saved view graphically

•
In the Saved View dialog, turn on the Show column.

• Click the Show column for the Saved View parameters to be displayed.

• Use the Selection tool to select the saved view graphics
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• Use the Selection tool to select the saved view graphics.

• Use the handles on the saved view graphics to modify the saved view.

• Views showing the saved view graphics (selected) and the modification handles.

• The Saved View dialog has a new column, Show. When Show is enabled for a saved view, 
graphics display its view parameters. In any view, the saved view graphics can be selected with 
the Selection tool, or by a fence, and manipulated like a standard element.

To modify a saved view graphically

• In the Saved View dialog, turn on the Show column.

• Click the Show column for the Saved View parameters to be displayed.

• Use the Selection tool to select the saved view graphics.

• Use the handles on the saved view graphics to modify the saved view.
Views showing the saved view graphics (selected) and the modification handles.
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View Attributes dialog

The View Attributes dialog allows you to apply a selected display style to a specific view or to all 
views. Added sections allow you to set global brightness, apply a saved view to a model, and view the 
forward, back, cut, outside clip volume.

Control presentation, view setup, and clip volume settings 

• Changes to the View Attributes dialog allows for better control of how the contents of a view 
display. In the Presentation section, you can choose a display style and global brightness, as well 
as turn on or off other display attributes. The View Setup section allows you to recall a saved 
view and to select the model to which the settings are applied. The Clip Volume Settings allows 
you to view different clip volume areas.

Display forward, back, cut, outside clip volume 

© 2008 Bentley Systems, Incorporated

p y , , , p

• The Clip Volume Settings section allows you to view the Forward, Back, Cut and Outside area of 
the clip volume.

Apply display styles to clip volume 

• Options in the Clip Volume Settings section allow you to apply display styles to the clip volume. 
The drop-down menu lists available display styles or click the magnifying glass icon to open the 
Display Styles dialog.

59 | WWW.BENTLEY.COM

Visualization Enhancements

The Visualization section has revamped with all tools reorganized into six toolboxes that are accessed 
from the Visualization toolbox.

• Each of the Visualization toolboxes contain tools pertinent to an area of visualization.

• Render — to render a view, save images to disk, save panoramas, query illumination, or create 
render setups.

• Lights — to place lights or sky openings, manage lights, or create light setups.

• Cameras to set up a view camera  or view  or to match a view to a photograph
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• Cameras — to set up a view camera, or view, or to match a view to a photograph.

• Materials — to define, apply, manipulate, query, or preview materials, and to manage 
environment maps.

• Material Projections — to attach, manipulate, or remove, material projections.

• RPC tools — to place or edit ArchVision RPC cells.
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Visualization Enhancements

Lighting levels consistent across all render modes from Smooth to Particle Trace 

• Changes to the way that lighting is processed means that lighting levels are now consistent 
across all render modes from Smooth to Particle Trace.

• Solar lighting is now consistent across all render modes, but note that Sky Lighting is not yet 
supported for Smooth.

• The display/color modes settings for Radiosity now look like those for Particle Tracing. The 
Intermediate/Final display options have been removed and a new toggle has been added for Ray 
Trace Specular Effects.

• A new option in the Ray Tracing settings dialog lets you set brightness mode to either Adapt to 
Brightness or Brightness Multiplier.

Brightness slider added for Smooth and Phong render modes 
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Brightness slider added for Smooth and Phong render modes 

• Smooth and Phong render modes now have a brightness slider to let you adjust the finished 
rendering.

Ambient & Flashbulb intensities now defined in Lux (lumens per square meter) 

• Ambient and Flashbulb intensities now have a physical value, Lux.

Smooth shading supports shadows 

• Smooth shading (in hardware) now supports shadows. That is, you can set the Display Style to 
display as Shadowed (Smooth shading with shadows).

• Hardware shadows are possible using the following Display Styles: Illustration with Shadows, 
Monochrome with Shadows, and Transparent with Shadows.

Lighting 

• Lighting has been enhanced and simplified, with new dialogs and new modifying methods for 
directional lights.
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Visualization Enhancements
Light Manager, consolidates all lighting controls into single dialog 

• The new Light Manager dialog lets you control all light sources in the model and its references. 

• For lighting in the active model, you can adjust settings, rename source lights, select previously 
saved setups, define North, or open the Light Setups dialog.

• For source lighting in references, you can view the settings and turn on or off the lights.

Light Setups store all lighting settings in DGN or DGN Library 

• The Light Setups dialog lets you create lighting setups with the lights in the model. That is, you 
can create setups that have different light states, such as on/off or changes in intensity 
(dimming), or with the same lights having different settings, such as the difference between day 
and night conditions. The position of the brightness slider for all render modes can be stored in a 
light setup.

Select Light Set p from all rendering tools and dialogs 
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Select Light Setup from all rendering tools and dialogs 

• The Light Setups dialog can be accessed from all render tools and dialogs.

Define Solar Lighting location from Google Earth 

• The Get Latitude and Longitude from Google Earth icon in the Light Manager lets you obtain 
Latitude and Longitude settings by <Ctrl> clicking on the required location in Google Earth.

Define sun and sky color from sun position 

• Physically based Sun and Sky color can now be determined from sun position (and also can be 
used as the environment).

New Place Light tool 

• A new improved Place Light tool incorporates all the settings required for the various light 
sources and Sky Openings. It provides better visual feedback, particularly for placing spotlights.
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Visualization Enhancements

Light Handles for positioning and targeting lights 

• You now can reposition and/or target directional light sources using their handles. To do this, you 
use the Element Selection tool to select the required light source and then drag the handles for 
the position and target to their new locations.

To position and/or target a directional light source

• Use the Element Selection tool to select the light source.

• Use the handles to reposition or retarget the light source.

• Where two or more light sources are targeting the same point, you can select them all and 
retarget them together in one operation.
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Improved area light rendering performance 

• Rendering of area lights has been improved to increase performance.

Distant Lights now treated as fill lights 

• Distant Light sources now are simple fill lights and are no longer treated as suns. They now:

• Can provide light in any direction, including upwards, under all circumstances.

• No longer have sky lighting applied to them (only Solar has this option).

• Are not confined to sky openings when present.
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Visualization Enhancements
Default Lighting 

• A new lighting view attribute, Default Lighting, has been added. When off, user-defined scene 
lighting, any Global Lighting, (ambient, flash and solar) or Source Lights (area, distant, point and 
spot lights) will be used.

• Default Lighting consists of a shadow casting light over the viewer´s shoulder, plus some ambient 
and a flash. This lighting is ideal for modeling in 3D, as it always provides very good illumination 
of a model relative to the observer. Because Default Lighting is a view attribute, you must turn it 
on (enabled) for it to be used to illuminate your model.

• To use Default Lighting, you must enable it for any view(s) where you want use it. This is done 
by clicking the Adjust View Brightness tool on the view border and turning on the Default Lighting 
toggle. When the Brightness tool is clicked, you will see a brightness slider and a toggle for 
enabling Default Lighting; checking the option turns on the Default Lighting for the view. The icon 
on the Adjust View Brightness tool changes to reflect the current state.
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• When the Display Mode of a Display Style is Shaded, that is, anything other than wireframe and 
hidden line, then the hardware renderer uses Default Lighting or the user-defined lights (Scene 
Lighting), depending on the Default Lighting view attribute.

• If a Light Setup other than From View is chosen, the Render tool overrides this view attribute and 
uses scene lighting.

• When using the Render tool, to see the effects of Default Lighting, turn on Default Lighting for 
the view you are rendering; make sure that Light Setup: From View is chosen. To render a view 
using scene lighting, you can chose any light setup other than From View, or render a view with 
Default Lighting off. If you choose Light Setup: From View and enter a data point, the current 
state of the view attribute Default Lighting for that view determines which lighting is used.
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Visualization Enhancements

Render Settings and Setups 

• Rendering settings and setups have been consolidated.

Single Render Settings dialog with basic and advanced interface 

• The Render Setups dialog has been reorganized. It has been consolidated into a single dialog with 
basic and advanced options.

Select Render Setup from all rendering tools and dialogs 

• All rendering tools and dialogs let you select Render Setup.

Distributed Rendering 

© 2008 Bentley Systems, Incorporated

• Distributed Rendering now is included and does not have to be downloaded as a separate 
package. Its basic requirement is that all processors taking part in the rendering have access to 
all the DGN, texture, RPC, and raster files to be used in the rendering. It is also necessary that all 
processors taking part in the rendering have access to the output path.

Simplified setup for Distributed Rendering 

• Setting up this new version of Distributed Rendering is simple and it does not require any 
external database server as was required previously. To use Distributed Rendering, you must first 
launch the Distributed Processing Controller from the MicroStation start menu. The first time that 
you start the controller you are prompted to define your Shared Directory. This determines where 
Distributed Rendering stores the information it needs to configure your controller and pass data 
back and forth between multiple machines. All machines that will participate in the rendering 
must have access to this shared directory.
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Visualization Enhancements
• When Distributed Rendering is available, the Bentley Distributed Processing Scheduler icon 

appears in the System tray.

Using Distributed Rendering to save images and animations 

• You can use Distributed Rendering to save an image, to save multiple images or to save an 
animation.

Distributed Rendering Related dialogs 

• The Scheduler is accessed by right-clicking the Process Controller tray icon and choosing Open 
Scheduler. The Job Monitor is accessed by right-clicking the Process Controller tray icon and 
choosing Open Job Monitor.

Scheduler 

• The Scheduler dialog is used to schedule times that your system is available for contributing to 
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processing images. 

Job Monitor 

• The Job Monitor dialog displays the progress of your distributed rendering tasks.

Animation 

• Animation now has support for additional formats and codec's.

Support for AVI and WMV video format output with user-selectable codecs 

• Animation now supports AVE and WMV video format output with user-selectable codec's. When 
you select Windows AVI or Windows Media (WMV) as the Format, the Codec option menu lets you 
select from a number of codec's.
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MicroStation V8i Overview

Thanks for attending!
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Thanks for attending!
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