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INTRODUCTION 

 
All Geopak products contain the same comprehensive set of Coordinate Geometry (Cogo) tools.  These tools 
can be used for a myriad of functions, from simple point storing and inversing, to more complex functions 
such as transformations and geodetic conversions. In this Beginner’s workshop we will explore some of the 
simpler and more commonly used Cogo functions. These functions will include:  
Inversing: determining distance an direction between stored coordinate pairs and multiple points 
Editing Functions: storing and editing simple Cogo elements, like curves, parcels and chains. 
Cogo Navigator: Using Geopak’s Cogo Navigator, to edit, describe and identify different types of elements. 
File Management: Creating Input and Output files, printing output results. 
Cogo Preferences: Customizing the Cogo Window, Editing Cogo preferences. 
These will be just some of the topics covered in this Beginner’s course. 
 
The GPK or Job file is the database used to store all coordinate geometry elements. It is a binary file so it 
can only be “read” by Geopak software. The name is limited to no more than 3 characters. Less can be used 
and the name can be a combination of alpha or numeric characters.  
 
Examples: 123, SR9, A1A, XXX 
 
Since this is your working database, it is important to make sure you have the correct GPK file loaded prior 
to starting any work. 
 
There are several ways to store Cogo elements. Elements can be stored by typing commands to the key in 
line of the Cogo window. Specialized dialogs for most functions can be accessed from pull down menus in 
the Cogo window. This makes it much easier to accomplish almost any task and prevents the need to 
memorize a vast array of commands to be typed in. Regardless which method you choose to use, the 
command itself will automatically be typed in to the key-in line and then executed. The advantage to this is 
each command is listed in the order which they are executed. This list of commands can be saved as an Input 
file. This file is saved in ASCII format and be edited easily. It can also be run again at any time and keeps a 
record of work performed. 
As you will see in some of the exercises, it is not necessary to actually type in element names in each 
window of the coordinate geometry dialogs. Windows in the dialog boxes can be easily populated by 
snapping to the elements in the DGN file.  
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Lesson No.1 - Cogo Preferences 

LESSON OBJECTIVE: 
This lesson will teach students how to change preferences for different projects.  
 
On-Line Help Topic: Coordinate Geometry > Preferences 

> EXERCISE: SETTING PREFERENCES 
In this exercise we will set the Cogo preferences we will use for the class. 
1. On the Desktop double click on the Microstation V8 Icon 

2. Open the design file: C:\IDDEA2006\BeginCogo\begincogo.dgn 

3. On the Microstation Tool bar go to: Applications  > Geopak Road > Geometry > 
Coordinate Geometry. 

Note  Keep in mind you do not need to access Project Manager first, to bring up a 
Coordinate Geometry dialog 

4. Fill out the dialog as shown below: 

                          
5. Press the OK button – This will activate the Coordinate Geometry dialog 
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6. In the Coordinate Geometry Dialog go to : File > Preferences > Dialog to access the 
preference window as shown below 

                          
 

 Job (GPK) Open Mode – method for verifying GPK file exists prior to work commencing 
 Job (GPK) Directory – location of GPK file to use or create 
 Cogo Input File Directory – location to store saved input files. If left blank will default to 

current Working Directory 
 Cogo Output File Directory - location to store saved output files. If left blank will default 

to current Working Directory 
 Redefinition of Elements – allows for editing or redefining of elements, must be checked 

ON to edit existing elements 
 Force Redefinition Off Upon Cogo Activation – insures Redefine is off, whenever cogo is 

activated 
7. Make certain the correct file path is set, and press the OK button 

 
 Lesson No. 2- Customizing the Cogo Window 

LESSON OBJECTIVE: 
This lesson will teach students how to customize the Cogo window to their preference. The Cogo 
window can be customized in many ways. The window can be resized, like any window by placing 
the cursor on the edge of the window and then dragging the edge of the window in or out until the 
desired size and shape is set. You can also choose which quick start icons are displayed. These icons 
take the user directly to the dialog for the specified tool, as opposed to using the pull down menu 
options. Buttons are also available to change  
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Preferences on the fly to suit the user’s requirements. Options on the format buttons are: 

                                                      
A “Check” mark indicates this button is “Active” or displayed in the Cogo window. 
 
On-Line Help Topic: Coordinate Geometry > Customization via the View tools 

> EXERCISE: CUSTOMIZING THE COGO WINDOW VIA THE VIEW TOLLS PULL-DOWN 
In this exercise we will quick start icons and preference shortcuts to the Cogo Window. 
 
1. In the Cogo window go to View > Icons > Customize this Group Scroll down to the 

Element / Point  category and check ON the Equate  and Station icons 

 

2. Press OK Once you return to the Cogo window you’ll note the new icons. 
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Next we will add a button that will allow us to change the number of characters after the 
decimal point for distances and coordinate values: 

3. Go to View > Format and click on Distance you can now change the decimal values by 
clicking on the button and setting it for the number of digits you wish to display. 

Note Care should be taken in the number of quick start icons and preference buttons chosen 
to be active. To prevent clutter, choose to activate only those functions used frequently 
in your course of work. 

 
 

 Lesson No. 3 - Storing and Locating Cogo Points 

LESSON OBJECTIVE: 
In this lesson we will look at the tools available to create/store points in Cogo. Points can be stored in 
a number of ways, by coordinates, locating from an existing point at a given direction and distance, 
etc.   
 

> EXERCISE: STORING POINTS BY COORDINATES 
In this exercise we will store 2 points by entering their coordinate values. Make sure you have 
Permanent Visualization  set. This will allow you to see the points as they are set. 
 
1. In the DGN file beginCogo.dgn go to : Utilities > Saved Views  and select the Saved 

View Store XY 

2. In the Cogo window go to Element > Point > Store and enter the information as shown 
below: 

                              
3. Press the Store Point button and the point will be stored in the center of the DGN file. 
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Note The point name has automatically incremented to the next number in the series, STO2 
4. Press the DP button and click on the screen near the first point stored 

Hint The DP button allows you to snap to a point in the file and generate coordinates directly 
from your DGN. This is especially helpful when you wish to set a point based on 
existing graphics. 

5. Press the Store Point button and the point will be stored where you snapped in the DGN 
file. 

Note You can add additional information to the point being stored by checking ON any of the 
boxes provided in the Store Point dialog and entering the desired information. This 
information will then be stored with the point. 

 
 

> EXERCISE: STORING POINTS TRAVERSE LOCATE COMMANDS 
In this exercise we will store 2 more points using the Locate Traverse dialog. The Locate 
Traverse dialog allows you to store points based on their relationship to points previously 
stored in the GPK file. This can be by Direction/Distance or Angle/Distance. 
1. In the Cogo window go to Tools > Locate > Traverse 

                
The Locate/ Traverse dialog has several different settings and options.  

Locate Point – The name of the point you wish to store 
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Elevation On – When this box is checked ON, elevation for the points located will be 
computed and stored based on Elevation of the Station Point,  Slope Distance/ Zenith Angle, 
and Target Height 

Side Shot Mode – When checked on will not move the Station Point up each time, which 
allows for Radial location computations 

Station Point – Point of origin or set up location. The Equate button allows user to select an 
existing PC, PT, PI, etc. from the GPK 

Direction – Allows user to determine method used to define direction to the new point. Press 
this button for multiple options. Includes an option to offset to the defined line 

Distance – Defines distance type and value 

2. Fill out the box as shown below 
Note You will have to change the distance button from Slope Distance to Distance 

                
3. Press the Locate button and point STO3 is now stored 

4. Change the direction to ANGLE and enter the angle as 270 leaving the distance value as 
65 

Note You’ll note that the Locate Point  and the Station Point were automatically incremented 
5. Press Locate button and point STO4 is now stored  
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 Lesson No. 4 – Inversing Between Stored Points 

LESSON OBJECTIVE: 
In this lesson we will look converting from Rectangular coordinates to Polar coordinates, more 
commonly referred to as Inversing between points. 
 

> EXERCISE: INVERSING BETWEEN POINTS BY KEY-IN COMMAND 
In this exercise we will inverse between previously stored points using the key-in command in 
the Cogo Window. 
 
1. In the DGN file beginCogo.dgn go to : Utilities > Saved Views  and select the Saved 

View Inverse1 

2. In the key-in line of the Cogo Window type INV IN1 INV2 

3. Note the distance and direction between the 2 points is shown in the output window, 

4. Now type in INV IN1 – INV4 you’ll note by the output this inverses between all points 
between INV1  and INV4 in numerical order 

 
 

> EXERCISE: INVERSING BETWEEN POINTS BY USING DIALOG 
In this exercise we will inverse between previously stored points using the available dialog 
box. 
 
1. In the Cogo window go to Tools > Inverse 

                 
2. The Point list window is where you can either manually type in the points, or you can 

click in the box, and then snap and select the points on the screen in the order you want to 
inverse. Type in INV3 INV4 and press the Inverse  button. The output will be displayed 
in the window. 

3. Clear out the point names in the Point List box and click inside to make sure that window 
is active.  

4. Select the points INV3 INV4 INV5 graphically by snapping to them on the screen 
5. Press the Inverse button. The output will be displayed in the window. 
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Hint The Inverse dialog contains an option to “Inverse Along Chain” if this option is used, the 
desired chain is selected and the courses along the chain will be displayed in the order 
they occur in the chain. This works something like the Describe Chain command with 
less detail. 

 
 

Lesson No. 5 – Computing Station and Offsets to a Chain 

LESSON OBJECTIVE: 
Computing the station an offset for a point to a chain is one of the most frequently used functions. 
However many find the key-in command confusing. The actual command which is Lay Off Chain 
confuses people, because they associate the term” lay off “with actually setting a point. 
 

> EXERCISE: DEFINING STATION AND OFFSET TO A CHAIN BY KEY - IN 
In this exercise we will compute the station and offset values for stored points using the key-
in command in the Cogo Window. The syntax for the command is: lay off chain (chain name) 
(point list) as you will see demonstrated below. 
 
1. In the DGN file beginCogo.dgn go to : Utilities > Saved Views  and select the Saved 

View Staoff1 

2. In the key-in line type the following command: Lay off chain staoff1 off1 –off10 

 
 
This is an example of the output for the first 2 points selected. Note in addition to the Station 
and Offset, Geopak provides the X,Y values for the points. A negative value for the offset 
signifies that point is to the left of the selected chain. 
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> EXERCISE: DEFINING STATION AND OFFSET TO A CHAIN BY DIALOG BOX 
In this exercise we will compute the station and offset values for stored points using the dialog 
box available through Cogo Window.  
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1. In the Cogo Window go to : Element > Chain > Layout Offset 

              
Baseline – The chain you wish to compute the station and offset from 

Element Option – This give you a few options. Select “Point” for station offset 

Point List – Points to be computed, can be typed in, snap graphically on the screen, taken 
from a selection set in the Navigator or from a Microstation Selection Set 

Elevation – Check this box ON if you wish to have the elevation of the points displayed as 
part of the output 

2. Fill out the dialog as shown above and press to Compute button 

The results will be displayed just as if you had typed the command in 
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Lesson No.6 – Storing Horizontal Curves 

LESSON OBJECTIVE: 
Horizontal curves are another type of Geopak Element. In the following exercises we will investigate 
the different options for storing curves. Curves can be stored by having existing points at the PC, PT 
and PI, or by defining the back and forward tangents together with another curve element such as the 
radius. There are a myriad of ways to store curves dependent upon the information available to you. 
Time does not permit us to go through every possibility, there for we will only address the most 
common situations. Since the syntax or order of the data required for key-in commands are rather 
lengthy, we will only use the dialog box in these exercises. 
 

> EXERCISE: STORING A CURVE BY TANGENTS 
In this exercise we will store a curve based on predefined tangents and a radius value. 
 
1. In the DGN file beginCogo.dgn go to : Utilities > Saved Views  and select the Saved 

View StoreCurve 

2.  In the Cogo window go to Element > Curve > Store > By Tangents 

                   
Note The Store Curve Dialog will change appearance based on the Tangent options selected 

3. Enter the name “c1” as shown above   

4. Click in the PC Point name box and then snap and accept the point TAN2 

5. For direction, click in the direction box then snap and accept point TAN1 and then snap 
and accept point TAN2                     
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Note When you snap and accept the first point, it will not show up in the dialog until you snap 
and accept the second point. 

6. Enter the radius as 100 and then either type in the Ahead Tangent as shown or snap to the 
points as you did for the back tangent 

7. When all the information is entered press the Store Curve button 
Hint Once the curve is stored the complete set of curve parameters will be shown in the 

Cogo output window. You can review the information to confirm the correct curve was 
created. You will also note that point symbols are placed at the PI and CC of the curve 
graphically. While no number/ name is attached to the points at the time the curve is 
stored you can refer to those points as “PI of C1” or “CC of C1”. Later if you desire you 
can place point names on these points using the Equate command. 

 

> EXERCISE: STORING A CURVE BY ENDPOINTS 
In this exercise we will store a curve based on predefined points at the PC, PT and PI 
 
1. In the Cogo window go to Element > Curve > Store > By End Points 

2. Enter the information in the dialog as shown below – keep in mind you can snap and 
accept the points on the screen or type in the values. 

                           
3. When all the information is entered press the Store Curve button – once again   you can 

review the curve parameters in the Cogo output window. 

 

> EXERCISE: STORING A CURVE CONCENTRIC TO AN EXISTING CURVE 
In this exercise we will store a curve concentric to the existing curve C2 
 
1. In the Cogo window go to Element > Curve > Store > Concentric 
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2. Enter the information In the dialog as shown below 

                                   
3. Once completed press the Store Curve button and the curve “C3” will be stored 50’ to the 

right of curve C3 
Note For curves to the left, simply place a minus sign ( - ) in front of the distance 

 
Lesson No.7 – Cogo Chains and Horizontal Alignments 

LESSON OBJECTIVE: 
Geopak contains 2 types of chains (linework) Cogo and Survey Chains. Cogo chains are two 
dimensional lines that can include curves and or spirals. Survey chains can be either 2D or 3D and 
can contain curves, but no spirals. In this lesson we will look at storing a Cogo chain containing angle 
points (PI) and curves. All chains have stationing applied automatically. You can define the 
beginning station or you can let the chain be stationed based on existing stations attached to the 
elements that comprise the chain. When curves are present, you do not need to store the PC or PT as 
part of the chain. Cogo will go from the last tangent point directly to the pc of the curve selected. 
Exiting the curve it will go from the PT directly to the next PI or next PC. Care must be taken as it is 
very easy to create Non-Tangent curves if these courses do not match the curve tangents. 
 

> EXERCISE: STORING A COGO CHAIN 
In this exercise we will store a Cogo chain based on pre-stored curves and points. 
 
1. In the DGN file beginCogo.dgn go to : Utilities > Saved Views  and select the Saved 

View StoreChain 

2. In the Cogo window go to Element > Chain > Store  > From Elements 
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Chain Name – Name of the chain you wish to store 

Begin 0.00 – Will station the chain beginning at 0+00 

Element Type – Pick list allowing you to select different types of elements from a list 

Element List – Elements that will or currently do, comprise the chain 

Point Name - Point name or element name to add to the chain 

Add - Adds the element in the point name field to the element list 

Store Chain – Executes the Store chain command 
Note  You can either select the elements from a pick list in the dialog or snap to the elements 

and have them automatically populate the list 
3. Set the Station option to Begin Station and type in  30+00 
4. Place your cursor in the Element List window and left to click to make this the             

Active window 
5. Next, snap and accept the first point in the alignment, at the far left (ch1) 
6. Then snap and accept the curve (ali1) 
7. Snap and accept the PI point (ch4) 
8. Snap and accept the last curve (ali2) 
9. Snap and accept the last point (ch7)  
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When completed the Element list should appear as below: 

 
10.  Press the Store Chain button and store the chain. 

Hint This same dialog is used for editing existing chains 
 

Lesson No.8 – Storing Parcels 

LESSON OBJECTIVE: 
Parcels are an individual Geopak Cogo Element, just like a point or curve. Parcels are extremely 
powerful elements. In each parcel, you can have multiple easements and takings stored. When 
Describing a Parcel, Geopak will break out these easements and takings individually, giving courses 
around each and the corresponding area. It will also show a total for all easements and all takings, 
plus the remainder area for the Parent Tract. Easements and takings can only be stored with an 
existing parcel. Attributes can be stored with each parcel. Attributes can be numerical (deed book 
and page) or text (land use). 
Parcels can be stored using more than one method. They can be stored based on existing elements, 
using the Store Parcel dialog. They can be stored using the Mapcheck dialog, if the elements do not 
exist yet but you know the courses around the parcel perimeter.  If all you have is graphic elements 
then you can create and store parcels using Autostore Graphics. In this lesson we will store parcels 
using the parcel Editor and the Mapcheck dialogs. We will cover storing parcels with the Autostore 
dialog in a later lesson on storing Graphic elements. 
 

> EXERCISE: STORING A PARCEL USING THE STORE PARCEL TOOL 
In this exercise we will store a Parcel based on pre-stored curves and points. The parcel store 
dialog works the same as the Chain store dialog. There are some differences due to the 
difference between parcels and chains. However we will store a parcel as we stored the chain 
by snapping to individual elements displayed on the screen. 
 

© 2007 Bentley Systems, Incorporated    17 



Florida Local User Group - Cocoa Beach, Fl. June 2007 

IDDEA Conference –October 2006  
GEOPAK COGO FOR BEGINNERS 

 

1. In the DGN file beginCogo.dgn go to : Utilities > Saved Views  and select the Saved 
View Parcelstore 

2. In the Cogo window go to Element > Parcel > Store 

 

                    
 Parcel Name – Name of the Parcel to be stored 

 Parent Tract – Determines if you’re storing the parcel, an easement or a taking. 

 Element List – List of elements comprising the parcel 

 Owner Name – Allows for the name of the owner to be stored with the parcel 

 Improvement – allows for improvements to be stored and a name, i.e. barn   

 Attributes  -  attribute information to be edited or stored 

3. In the parcel Name field enter the name Parcel1 

4. Set for Parent Tract 

5. Left click in the Element List window to make it active and then snap and accept the 
elements in the DGN file in a clock wise direction, stating from point PAR1 in the bottom 
left of the screen. 
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When Step 5 is completed the Element list box should appear as below: 

      
6. Press the Parcel Store button 

Note It is important to remember to include the first point in the parcel as the last point in the 
parcel to close it. If the parcel begins on a curve, you should use the Equate command 
to set a point on the PC to close to. 

 

 

> EXERCISE: STORING A PARCEL USING THE MAPCHECK TOOL 
Many times we will have to store a parcel based on the information as found in a written 
description. In this exercise we will store a Parcel based on the bearing, distances and curve 
information that make up the courses of the boundary of the parcel. The Mapcheck tool, 
allows you to check the closure precision of the parcel prior to storing. This makes it easy to 
determine if an error was made in the input or in the legal description used to create the parcel 
prior to storing it. This tool can also be used to either edit an existing parcel’s courses or to 
add easements and takings. 
The Preferences lets the user determine if they want to store point names at the PC, PT, and 
CC of curves. It also determines the method of precision to be used in determining the closure 
accuracy of the parcel. 
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1. In the DGN file beginCogo.dgn go to : Utilities > Saved Views  and select the Saved 
View Mapcheck 

2. In the Cogo window go to Tools > MapCheck 

       
Parcel Name – Name of the Parcel to be stored 

Parent Tract – Determines if you’re storing the parcel, an easement or a taking. 

Curve Parameters – The type of curve information the be entered 

Preferences – Sets the preferences for curves and closure 

Starting NEZ – Beginning point or coordinate 

Course Description – Shows the courses around the parcel 

Input windows – where direction, distance, curve information is input and  edited 

Bearing – Determines the method to be used when defining direction. Methods 
Supported are Bearings, Azimuth and QDD.MMSS 

Rt/Lt – Curve direction 

+… - Add information to the Course Description window 

…+ - Copy highlighted line in the Course Description window 

-  - delete highlighted line in the Course Description window 

/ - Modify highlighted line in the Course Description window 

Clr Input – Clears all courses from the Course Description window 

Scale – allows a scale factor to be applied to distances 
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Clear Parcel - Clears Parcel name all courses from the Course Description window 

Store Parcel – Stores the parcel in cogo based on the displayed courses 

Describe Parcel – Describes the parcel boundaries and areas if the parcel is already 
stored 

Closure – Traverses the displayed courses and check for precision of closure 

 
3.  Click on the Preferences  button and fill out the dialog as show below: 

                                        
4. Click on the Begin NEZ button and select the point Map1 and press  Enter then close the 

window 

5. Type in the parcel name as Map1, type as Parent, and curve parameters to Radius and 
Delta 

6. The first course will type in is N 78° 53' 02" E Dist 235.060     point name Map2                                   

7.   The Second course     S 88° 59' 22" E Dist 186.070    point name Map3                                                

8. Now a Curve  Radius 343.62 Delta 65 15 29 RT curve name Mapc1 

9. Below are the remaining courses: 

        S 23° 43' 53" E Dist 201.870                                                                  

        S 56° 43' 28" W Dist 386.010    

        Radius = 172.820   Delta = 68° 41' 26" (RT)  

        N 45° 35' 06" W Dist 235.870   

        N 17° 00' 29" W Dist 321.637                                                             
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10.   Now press the Closure button and check the closure in the Cogo output window. 

       $ Error North: -53.093   Error East: 29.158                                                                                    

                $ Error North: -53.093   Error East: 29.158                                                                 

            $ Error Direction: N 28^ 46' 30" W   Total Distance Error: 60.572   

            $ Error of Closure: 1/35.744      

As you can see the parcel does not close very well. We need to edit one or more of the 
courses to correct the problem. 

11. Click on the third line down so it’s loaded into the edit boxes. Change the bearing from 56 
degrees to 65 and the press the “ / “ to modify the line 

12. Now press the Closure button again and you see the Parcel closure is correct 

13. Press the Store Parcel button and Geopak runs the courses to create the points and curves 
then stores the parcel. 

 
Lesson No.9 – AutoStore Graphics 

LESSON OBJECTIVE: 
AutoStore Graphics allows users to store cogo elements (points, curves, lines, chains and parcels) 
from graphic elements in the design file. It works both with DGN and DWG file formats. There is no 
need to store different types of elements individually as they can be selected and stored in one task. 
You can also apply individual features to each different type of element when they are created. While 
this tool is not available through the Cogo window as all the tools we have used so far are, it is 
available in each of the different Geopak Modules. 
 

> EXERCISE: STORING COGO ELEMENTS USING AUTOSTORE GRAPHICS 
In this exercise we will store a series of cogo elements from graphic elements.  
 
1. In the DGN file beginCogo.dgn go to : Utilities > Saved Views  and select the Saved 

View Autostore 

2. On the Microstation tool bar go to: Applications > Geopak Road > Geometry > Auto 
Store Graphics 
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Job Number – GPK file you wish to store elements in 

Get Selection Set from – Which elements in DGN or DWG you wish to store 

Elements – Type of elements you wish to store 

Feature – Feature code you wish to attach to elements (Default setting is default feature) 

Flood Parcels – Settings for parcel selection criteria 

Elevation – Attach elevation to point determination 

3. Set the AutoStore dialog as shown above 
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4. Click on the Text Symbology box in the flood parcel section and set the Text criteria for 
parcels as shown below and press OK: 

                                           
5. Press Apply button – Note this may take a minute or two to store or elements 

6. Check the Cogo Output window and verify all elements were stored.  
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