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Building Toolbars in XM    
 

Overview 

MicroStation V8 XM Edition provides new methods of standardizing element placement 
through the use of tasks, element templates, and custom tools delivered in the drawing 
environment through the use of DGNLIB's. This workshop will cover the new task-based 
interface in the XM Edition. Learn how to create element templates to set attributes as well as 
tie the templates to custom tools delivered as part of a task-based interface. 

Objectives 

After completing this workshop, you will be able to: 

 Enforce standards with element templates 
 Create tasks and menus and add tools 
 Migrate stg resources and import an m01 file 
 Report on and manage customizations 
 Export and import customizations to XML 

 

Introductory Knowledge 

Before we begin, answer the following questions. They reflect upon your organization’s 
standards and workflow because these are important considerations when you approach 
customizing the interface. 

1. What is a design library, or DGNLib? 

2. What is your current method of applying standardized element attributes? 

3. Do you have legacy customizations? 
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Introductory Knowledge Answers 

1. A DGN library contains standard definitions for things such as levels, text and dimension 
styles, cells, etc. that are shared throughout files and by members of a workgroup. When 
you use a definition from a DGNLib, it is copied to the active file and is given the same 
name. You can compare the local resource to the DGNLib to see if the DGNLib has 
changed, or if the local resource is out of sync with the DGNLib. 

2. This is important because it helps define ways in which element templates, tools and 
tasks can be implemented to help standardize production. 

3. Settings Manager settings files and existing .m01 resources can be imported for use in 
MicroStation V8 XM Edition. You can then use the new tools to organize and enhance 
those customizations. 

 

Customizing the User Interface 

Element Templates, custom tools, tasks and menus are created and managed in the Customize 
dialog. 

Tools can be customized to simplify design tasks. You can apply a specific set of tools, 
standards and interface elements to a particular task in a workflow so users can work 
consistently. These are stored in a DGNLib file. 

 

Enforcing standards with element templates 

Element templates are named sets of element parameters that can be used to set active 
element placement parameters. A user selects an element template, which activates the 
settings stored in the template and can also activate a key-in command stored for that 
template. Element templates are similar to, but much more flexible than, Settings Manager 
components. 

You can create templates and apply them to tools to ensure that elements placed using the 
tool conform to specific standards. Use templates to further enforce standards by storing them 
in DGNLibs. 
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Element Selection can show all the element templates within the active file. You can use the 
list on the Templates tab to select and deselect elements based upon the template that was 
used for their placement. 

 

Creating element templates 

 Exercise: Create an element template 

1. Set the following in the MicroStation Manager: 

User: CADD_Admin 

Project: CADD_Standards 

2. Move up one level and open \Dgnlib\Civil.DGNLIB. 

This DGNLib contains the tools, tasks and templates available for a project. 

3. Select Workspace > Customize. 

4. On the Templates tab of the Customize dialog, expand Civil.DGNLIB by clicking the +. 

5. Expand the Survey Template Group. 

6. Select Building. 

7. Check the General Settings properties. 

Any time that this template is applied, users will place elements on the SV_Building 
level, using color 0, style 0 and weight 3. 

 

Additional template properties 

Right click in the area below the existing properties to open the Add pop-up menu. Use it to     
add more properties to the selected template. These can be General Settings such as Level,  
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Color, Line Style Attributes, and Class. They can also be Closed Linear Settings such as fill 
type or color, pattern parameters, text settings, cell settings, Multi-line styles or Dimension 
styles. 

You can also right click on a template and select Add to add additional property fields to the 
template. 

 Exercise: Exercise: Create a template 

1. Continuing in Civil.DGNLIB, select File > New from MicroStation’s main menu bar. 

2. Create a new DGNLib named Bridge.DGNLIB in the DGNLIB folder. 

3. Create the following Levels: 

Level Color Line Style Weight 

BRDG_Base 
BRDG_Concrete 
BRDG_Dimension 
BRDG_Earth 
BRDG_Rebar 
BRDG_Text 

118 
32 
0 
85 
6 
0 

0 
0 
0 
0 
0 
0 

1 
2 
0 
0 
1 
0 

4. On the Templates tab of the Customize dialog, select Bridge.DGNLIB. 

5. Right click and select New Template Group. 

6. Name the group Bridge. 

7. Select the group. 

8. Click New Template, or right click on the template group name, and select New 
Template from the pop-up menu. 

9. Name the new template Concrete. 

10. Click on the new template and set the following properties: 

Color: ByLevel 

Line Style: ByLevel 

Weight: ByLevel 

These attributes have already been established in the definition of the level. 

 

Setting and locking templates 

Element templates are activated using the Active Template tool in the Attributes tool box. It 
provides a list of available templates and also serves as a toggle to lock new elements to the 
active template during placement. While element templates are similar to Settings Manager 
components, elements that are placed with a template locked are automatically updated when 
parameters in the element template are modified. 
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There is an important difference between setting and locking the active element template. In 
both cases elements will have properties that are defined in the template. But they will 
ultimately behave differently. 

When you set the template by selecting one from the hierarchy tree, the active attribute 
settings change to the properties defined in the template. When you place an element, the 
element will have the template’s properties but it is not locked to the template. If the template 
properties are changed and a library update is issued, these elements will not change. 

When a template is locked, the active attribute settings change to the properties defined in the 
template and elements will have the template’s properties. Elements are also associated with, 
or locked to, the template. If the template is stored in the active file, these associated elements 
will update automatically when properties in their template are modified. If the template is 
from a DGNLib you can use the DGNLIB UPDATE TEMPLATES key-in to synchronize 
properties. This is similar to text and dimension styles. 

To lock a template, set the template by selecting one from the hierarchy tree then click the 
Active Element Template icon so that it is depressed. 

Updating elements using templates 

If a template was used while placing elements and a user manually changes element 
symbology so that it doesn’t match the template, you can issue a command to update the 
symbology. Select Utilities > Update Selected Elements in the Customize dialog to update 
the symbology of all elements in a selection set that are associated with local templates. If an 
element that is not associated with a template is selected, its symbology will not change. 

Note: Select Utilities > Refresh Local Element Templates in the 
Customize dialog to update the template list with element 
templates from DGNLibs. 

Key-ins 

Use the key-in CUSTOMIZE DELETEALLDATA to delete all template data and all custom 
tool box, tool, task, and menu data from a DGN file. All elements that are associated with the 
templates being deleted will no longer be associated with the templates. 

Use the key-in CUSTOMIZE RELOAD to reload all template data and all custom tool box, 
tool, task, and menu data into a DGN file. Use this key-in if DGN libraries are updated and 
you want to reload data to make it available while working in MicroStation. Closing a DGN 
file and reopening it will produce the same result. 

 

Creating tasks 

 Exercise: Note the tasks 

1. Continuing in Civil.DGNLIB, click the Task List icon. 
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All the tasks defined by MS_DGNLIBLIST are listed along with the default 2D tasks, 
Drawing and Drawing Composition. 

2. In the Customize dialog, select the Tools tab. 

Tools, tool boxes, tasks and menus are defined on the Tools tab of the Customize dialog. 

If you are not working in a file that is identified in MS_DGNLIBLIST (Workspace >  
Configuration, Primary Search Paths category, DGN Library List) you will see a warning 
message. Tool, task and menu customization can be performed only in files that are 
configured DGN libraries. 

3. Click the File menu in the dialog. 

Available DGNLibs are listed on the File menu. If you attempt to access the Tools tab 
and see the warning message, you can select the File menu and select a listed DGNLib so 
you can use the tab. 

Personal DGNLibs 

When a user creates a new Interface in the MicroStation Manager, not only is a new ustn.r01 
file created, a user specific DGNLib is also created. The name of this DGNLib is the same as 
the name of the user interface. Anyone can open this new DGNLib and add custom tools, 
tasks and menus that are unique to them (that User). 

The Primary Search Path category, User Interface DGN Library List variable, 
MS_GUIDGNLIBLIST, includes the path to DGNLibs in the current user interface folder. 
$(_USTN_USERINTNAME)\*.dgnlib. 

Warning: Anyone can copy other DGNLibs to their user interface folder, so that tools, tasks and 
menus from those files are also loaded. Tools, tasks and menus in the user interface 
folder will be the first ones loaded and will have precedence if duplicates exist in the 
DGNLibs referenced by MS_GUIDGNLIBLIST. 

Creating tasks and adding tools 

Once a task is created you can add existing tools or tools that you define in the Customize 
dialog. You can use any MicroStation tool or any existing custom tools you have previously 
defined in an m01 file. 

 Exercise: Compose a task containing tools from different tool boxes 

1. Open Civil.DGNLIB, on the Tools tab of the Customize dialog, expand User Tasks in the 
right frame. 

2. Select Civil.DGNLIB, next to the V8 icon. 

3. Click New Task. 

The task list expands and a new task is added. 

4. Name the new task Landscaping. 

Note: A right click menu for each task offers a Rename option as 
well as options for reordering, creating and deleting tasks. 
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5. In the left frame, expand Application Tools, then MicroStation. 

All MicroStation’s tools are listed here. 

6. Scroll to the Measure tools. 

7. Drag the Measure tools to the Landscaping task in the right frame and drop them. 

You can add entire tool boxes or individual tools. 

8. Scroll to the Polygons tools. 

9. Drag these tools to the Landscaping task. 

If you make a mistake, Undo works on these drag and drop operations. 

10. Scroll to the Modify tools. 

11. Drag these tools to the Landscaping task. 

Editing tasks 

Once you add a tool box to a task, you can edit the tools it contains. 

 Exercise: Refine the task 

1. Continuing in Civil.DGNLIB, on the Tools tab of the Customize dialog, expand the 
Measure tools in the Landscaping task. 

You will keep only the tools that are relevant to the landscaping task. 

2. Select Measure Volume, right click and select Delete. 

You can select multiple tools or tasks and use the Customize dialog Delete icon to delete 
them. 

3. Select Measure Radius and Measure Length and click Delete, clicking Yes in the alert. 

4. Expand the Polygons tools and delete Place Regular Polygon and Place Orthogonal 
Shape. 

5. Edit the Modify tools to only include the first five tools. 
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Warning: Since tools are referenced into Tasks, changing a tool’s function can affect many 
tasks. 

 Exercise: Reorder the tasks 

1. Continuing in Civil.DGNLIB, click the Task List icon. 

The Landscaping task is added to the task list. 

2. Expand it to see that the tool boxes you added are available. 

You can reorder tasks themselves and also reorder the tools within a task. 

3. Use the move up and down arrows, or drag and drop, to arrange the tool boxes in the 
Landscaping task in the following order: 

Polygons 

Measure 

Modify 

4. Click the Task List icon. 

5. Click the Landscaping task. 

The reordered Landscaping tasks are added to the interface. 

 

Use tasks to define a workflow 

You can compose a series of tasks that help define a complete workflow. 

 Exercise: Compose a workflow 

1. Continuing in Civil.DGNLIB, in the Customize dialog, select the Dimensioning tools 
from the MicroStation application tools in the left frame. 

2. Drag them to the Civil.DGNLIB task and drop them. 

 

 

The Dimensioning tools are now an overall task. 

3. Select Civil.DGNLIB and click New Task. 

4. Name the task Planning. 
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5. Reorder the tasks as follows: 

Planning 

Dimensioning 

Landscaping 

6. Select Civil.DGNLIB and click New Task. 

7. Name the task Printing. 

8. Drag the Print tool from the Standard tools in the left frame to the Printing task. 

Adding custom tools 

 Exercise: Create a custom tool 

1. Continuing in Civil.DGNLIB, in the Customize dialog, expand User Tools in the left 
frame. 

2. Select Civil.DGNLIB. 

3. Click New Tool Box. 

4. Name the new tool box Plants. 

5. Select the new tool box and click New Tool. 

6. Name the new tool Place Trees. 

7. Select the new tool. 

8. In the Properties section of the Customize dialog, in the Command Data section, remove 
null and type the following in the Key-in input field: 

PLACE REVCLOUD POINTS 

9. Change the Balloon Text to Place Trees. 

10. In the General Settings section, click in the Icon input field, and then click the browse 
button on the right. 

In the Define Icon for Tool dialog, you’ll be choosing tools from the MicroStation 
application. 

11. Expand MicroStation. 

12. Scroll to the Cells tools and expand them. 

13. Select Place Active Cell Matrix and click OK. 

The icon displays in the icon field. 

You can display a tool’s icon, or label, or both by setting the Tool Presentation. 

14. Set Tool Presentation to Icon Only. 
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Tool icons 

In the Define Icon for Tool dialog, the Look for icons in options let you select the source 
from which you want to select, import, or delete icons for custom tools. 

 Applications contains the icons listed under Application Tools in the Customize 
dialog. It includes all MicroStation tools and MDL application tools. 

 Current Design File is the only source from which you can delete icons. 
 Import Selected Icons is the source to use to import icon (ICO) files. 
 Import Selected Bitmaps is the source to use to import bitmap (BMP) files. 

Import/export 

Use the key-in CUSTOMIZE EXPORT ICONS <path\directory\> to export icons from the 
open DGNLib to a directory. You may want to export icons in order to edit them. 

Note: Only the icons shown in the Define Icon for Tool dialog when 
Look for icons in is set to Current Design File will be exported. 

Use the key-in CUSTOMIZE IMPORT ICONS <path\directory\> to import icons from a 
directory to the open DGNLib. 

Warning: When importing icons, imported icon will replace existing icons of the same name. 

Note: You can use MicroStation to create geometry then select 
Utilities > Image > Capture to capture an image. Then, use an 
image editing application to refine the image. 

General settings for user tools 

The Tool Type options specify the behavior of the tool. 

 Standard makes the tool active until you select another tool. 
 A Push Button will not start a new command and does not interrupt a current 

placement command. Use this to send immediate command key-ins. For example, the 
key-in CO=1;LV=Landscaping would set the active color and level. 

Dimension options determine whether a tool will be available when working in 2D DGN files, 
3D DGN files, or both. 

Adding advanced tools 

Since you can use any MicroStation key-in as the command string, you can predetermine tool 
settings or open documents. You can also link to a website. 

You can use % to link to any document. For example, %C:\temp\CADstandards.doc. 

or 

%www.census.gov 
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Also,  

! C:\temp\Lot_Design.txt opens the text document in the application associated with the .txt 
extension. 

 

 Exercise: Add tools to a task 

1. Continuing in Civil.DGNLIB, in the Customize dialog, drag the Plants tool box to the 
Landscaping task in the right frame. 

2. Note the active tasks. 

The Plants tool box has been added. 

3. Click on Plants in the task list so that the Plants tools will occupy the Task Navigation 
tool box. 

4. Click the Place Trees tool. 

Tool settings change to reflect the command string you entered. 

You can also create tools that open dialogs or perform repeated user actions. 

 

 Exercise: Tools that open dialogs 

1. Continuing in Civil.DGNLIB, in the left frame of the Customize dialog, expand the 
Primary Tools in the MicroStation Application tools. 

2. Drag the References tool to the Printing task. 

3. Click the Task List icon and select the Printing task. 

The References tool is added to the task. 

Apply an element template to a tool 

You can apply element templates to tools so that the attributes in the template are always 
invoked with the tool is used. You can import settings from existing Setting Manager resource 
files and to import and export element template definitions using XML files. 

A custom tool with a template attached is referred to as a structured workflow. 

 Exercise: Define attributes for a placement tool 

1. Continuing in Civil.DGNLIB, in the left frame of the Customize dialog, select the Place 
Trees User Tool in the Plants tool box. 

In the Command Data section, you can set the template path. 

2. Click in the Template Path input field and navigate to the Design > Trees template. 
Double click the Trees template to apply it. 

3. Open the task list and click the Landscaping task. 
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4. Select the Place Trees tool. 

Note the change in the tool and active attributes settings. 

 

Additional command data settings for tools 

The Associate Template setting sets the status of the Active Element Template tool in the 
Attributes tool box when a tool is used. 

 When Always is selected, the icon is available. 
 Never makes it unavailable. 
 Use Current Setting does not change the status of the icon. If the icon is available and 

a template is defined, elements that users place with the tool will be placed with the 
template settings. 

If you right click in the Associate Template field there is an Add Default Template option. If 
you set one, when the tool is used, the default template’s properties are applied to the 
element. If a template property is specified in both templates, the associated template takes 
precedence. 

Managing tool settings 

Another feature is the ability to control tool settings. Other options for customizing tools are 
also available. 

 Exercise: Add customization options to the Customize dialog 

1. Continuing in Civil.DGNLIB, on the Tools tab of the Customize dialog, select the Plants 
tool box. 

2. Create a tool named Border. 

3. Select the tool and set the following properties: 

Key-in: PLACE SMARTLINE 

Balloon Text: Place Border 

Icon: MicroStation > Linear Elements > Place SmartLine 

Tool Presentation: Icon Only 

4. Right click in an empty area of the Properties section at the bottom of the Customize 
dialog. 

5. Click Add and select Dialog Item Settings from the pop-up menu. 

A Dialog Item Settings field is added to the dialog. Use this area to set tool settings 
parameters. 

Note: To find out the available tool settings for a command you can 
use the key-in SET ITEM TOOLSETTINGS. To do so, invoke 
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the tool in MicroStation and then issue the key-in. The options 
are listed in the right frame of the Key-in browser. 

 Exercise: Preset tool settings 

1. Continuing in Civil.DGNLIB, in the Item Settings section of the Customize dialog, 
expand Dialog Item Settings. 

2. Set the following: 

Dialog Item Name: ToolSettings.Join 

Type: Literal 

Value: 1 

This enables the Join Elements check box in the Place SmartLine tool settings. 

3. Right click on the Item Settings heading and select Dialog Item Settings. 

Additional dialog items can be specified this way. 

4. Set the following for Dialog Item Settings(1): 

Dialog Item Name: ToolSettings.vertextype 

Type: Literal 

Value: sharp 

5. Drag the Border tool to the Plants tool box in the Plants task. 

6. Make the Plants task active in the Task Navigation tool box.  

7. Select the Place Border tool and note the tool settings. 

8. Select the default Drawing task from the task list so those tools occupy the Task 
Navigation tool box. 

The Type option determines the type for the dialog item. It can be literal, as in the above 
exercise, a distance stored in meters, an area stored in square meters, or a volume stored in 
cubic meters. The Value is the value for the Type. If the tool places a line that is constrained, 
one of the dialog items would be the line’s length, which is Type distance. The Value would 
preset the length of the line. 

 

Additional tool properties 

You can also access available tool properties if you right click on a new tool and select Add 
from the pop-up menu. 

Expand the options on this menu to add design file settings such as the active snap mode or 
an active angle. Fence modes can be set. Use the Locks options so that the tool uses the graphic 
group lock or the annotation scale lock. You can also apply fence settings such as clip or overlap. 
The command data submenu lets you add a field so you can define a default template. 



Migrating stg resources 

 

Delivering Standards with MicroStation XM 14 May-08 

Copyright © 2008 Bentley Systems Incorporated 

Migrating stg resources 

Legacy .stg resources can be imported and be used as tools and templates. The settings file 
groups become individual tool boxes. Their components are tools that maintain all their 
specific settings. Each group also becomes a template, containing all attribute settings. 

 Exercise: Migrate existing customizations 

1. Continuing in Civil.DGNLIB, in the Customize dialog, select File > Import > From 
Settings Manager. 

2. In the Select Settings File to Import dialog, navigate to 
\Workspace\System\data\styles.stg and click Open. 

A new tool box named after the DGN file is added to the Civil.DGNLIB User Tools. 

3. Right click on the Civil.DGNLIB tool box and select Rename. 

4. Rename the tool box Building. 

5. Expand the Building tool box and note the tool boxes listed. 

There is one for each Settings Manager group. 

6. Expand one of the tool boxes and select a tool. 

You can see any key-in associated with the tool, along with any other properties that were 
set for the component. The Template Path specifies the element template from which the 
attributes such as color and weight will come. 

7. Drag the Building tool box to the root level Civil.DGNLIB lib task and drop them. 

8. Move the Building task under the Planning task. 

The new tools are ready for use. 

 

Importing an m01 file 

To import a legacy .m01 file, first create an Interface folder for the .m01 file (for example, 
\Workspace\Interfaces\OldInterface) in Windows Explorer. Place the .m01 file there. Then 
open MicroStation using that interface.  

When you open the Customize dialog, the customizations from the .m01 file will appear under 
the MicroStation Application tools. Work with them now just as you would default MicroStation 
Application tools. 
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Reporting on customizations 

You can generate an HTML report on all the template, custom tool box, custom tool, task, 
and custom menu data in the active file. 

 Exercise: Report on the customizations 

1. Continuing in Civil.DGNLIB, in the Customize dialog, select Utilities > Generate HTML 
Report. 

2. Specify a name and location for the HTML file in the Define HTML Report File dialog. 

The default is to create a file named after the DGN file in the current folder and click 
Save. 

An HTML file opens. It contains information about all the template, custom tool box, 
custom tool, task and custom menu data in Civil.DGNLIB. 

3. Exit the HTML file. 

Exporting and importing customizations to XML 

You can import and export to XML files in order to edit tool boxes, tools and templates with 
an XML editing tool. 

Once user tools and tasks have been created, select File > Export > XML in the Customize 
dialog. Then, select a location and name for the file. 

 

Working with Menus 

You can edit and create menus on the Tools tab of the Customize dialog. 

Creating menus 

Select Menu from the Tasks/Menu option list above the right frame. Then use the tools 
provided to create new menus and menu items. 

 

 Exercise: Create a menu 

1. Continuing in Civil.DGNLIB, in the Customize dialog, select the Tools tab. 

2. Select Menu from the Tasks/Menu option list. 
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3. Select Main Menu. 

4. Click New Menu.  

5. Rename the new menu Civil Design. 

To insert a mnemonic, insert the tilde character before the character you want to be the 
accelerator. 

6. Place the cursor at the beginning of the word Building. 

7. Press Shift + ~ before the C in Civil Design. 

~ Civil Design 

8. Select the menu and click the up arrow, or drag and drop, to move it above the Help 
menu. 

9. Right click on the Civil Design menu. 

10. Select New Menu from the pop-up menu.  

11. Name the new menu Tools. 

Adding tools to a menu 

 Exercise: Add tools to the menu 

1. Continuing in Civil.DGNLIB, select User Tools in the left frame. 

2. Expand Civil.DGNLIB. 

3. Select the Plants tool box and drag it to the Tools submenu. 

The tools are now accessible from the main menu bar. 

You can also create a menu entry that opens a tool box. 

4. Right click on the Tools submenu and select New Menu Item. 

5. Rename the new menu item Modification. 

6. In the Properties section of the dialog, Command Data section, type the key-in: 

CUSTOMIZE OPEN TOOLBOX MODIFY 

7. Select Civil Design > Tools > Modification to open the tool box. 

Menu items 

 Exercise: Add additional menu items 

1. Continuing in Civil.DGNLIB, in the right frame of the Customize dialog, right click on 
the Civil Design menu. 

2. Select Add New Menu Separator. 
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3. Right click on the Civil Design menu and select New Menu Item from the pop-up menu. 

4. Name the new item Dimension Styles. 

5. In the Properties section of the dialog, Command Data section, type the key-in: 

MDL KEYIN DIMSTYLE DIALOG DIMSTYLE OPEN 

The Dimension Styles dialog can be opened from the custom menu. 

6. Right click on the Civil Design menu and select New Menu Item. 

7. Rename the menu item Landscaping. 

8. Type the key-in: 

CUSTOMIZE OPEN TASK Landscaping 

This entry opens the Landscaping tasks that you created as a tool box. 

9. Select File > Close. 

Additional menu properties 

As with tools, the Dimension options determine whether a menu will be available when 
working in 2D DGN files, 3D DGN files, or both. 

The Shortcut field for new menu items lets you select shortcut keys to be used when selecting 
a menu item. If a shortcut is already used, it is dimmed in the list of options and is not 
available. 

 

Review 

In completing this module you have learned how to: 

 Enforce standards with element templates 
 Create tasks and menus and add tools 
 Migrate stg resources and import an m01 file 
 Report on and manage customizations 
 Export and import customizations to XML 

 

 

 

 


